(HDU 5791)Two <DP求公共子序列的个数> 多校训练5

Two
Problem Description
Alice gets two sequences A and B. A easy problem comes. How many pair of sequence A’ and sequence B’ are same. For example, {1,2} and {1,2} are same. {1,2,4} and {1,4,2} are not same. A’ is a subsequence of A. B’ is a subsequence of B. The subsequnce can be not continuous. For example, {1,1,2} has 7 subsequences {1},{1},{2},{1,1},{1,2},{1,2},{1,1,2}. The answer can be very large. Output the answer mod 1000000007.

Input
The input contains multiple test cases.

For each test case, the first line cantains two integers N,M(1≤N,M≤1000). The next line contains N integers. The next line followed M integers. All integers are between 1 and 1000.

Output
For each test case, output the answer mod 1000000007.

Sample Input
3 2
1 2 3
2 1
3 2
1 2 3
1 2

Sample Output
2
3

Author
ZSTU

Source
2016 Multi-University Training Contest 5

题意:
求A,B的公共子序列的个数?

分析:
对于求最长公共子序列的问题我们可以很快的求出。而这一题我们可以从求最长公共子序列问题中得到启发。
不过这一题我们要注意去掉重复的情况。
dp[i][j]表示考虑A的前i个数,和B的前j个数之间的公共子序列
当A[i] == B[j] :dp[i][j] = dp[i-1][j] + dp[i][j-1] + 1;
否则: dp[i][j] = dp[i-1][j] + dp[i][j-1] - dp[i-1][j-1] ;

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <cmath>
using namespace std;

const int maxn = 1010;
const int mod = 1e9 + 7;
int a[maxn],b[maxn];
long long dp[maxn][maxn];

int main()
{
    int n,m;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        for(int i=1;i<=n;i++) scanf("%d",&a[i]);
        for(int j=1;j<=m;j++) scanf("%d",&b[j]);
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=m;j++)
            {
                if(a[i] == b[j])
                    dp[i][j] = (dp[i][j-1] + dp[i-1][j] + 1) % mod;
                else
                    dp[i][j] = (dp[i][j-1] + dp[i-1][j] - dp[i-1][j-1] + mod) % mod;
            }
        }
        printf("%d\n",dp[n][m]%mod);
    }
    return 0;
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值