HDU1671 Phone List(字典树)

Time Limit: 1000MS Memory Limit: 32768KB 64bit IO Format: %I64d & %I64u

 Status

Description

Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers: 
1. Emergency 911 
2. Alice 97 625 999 
3. Bob 91 12 54 26 
In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent. 

Input

The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.

Output

For each test case, output “YES” if the list is consistent, or “NO” otherwise.

Sample Input

2
3
911
97625999
91125426
5
113
12340
123440
12345
98346

Sample Output

NO
YES

简单字典树,注意数组要开到10000*10,因为有这么多个节点。。。

代码如下:

#include<iostream>
#include<cstring>
#include<algorithm>
#include<string>
using namespace std;
const int maxx=10050;
int ch[10*maxx][15];
int value[10*maxx];
string ss[maxx];
int sz=0;bool flag=true;
void init(){
sz=1;flag=true;
memset(ch[0],0,sizeof(ch[0]));
memset(value,0,sizeof(value));
}
void insertstr(string str){
int u=0,n=str.length();
for(int i=0;i<n;i++)
{
    int d=str[i]-'0';
    if(!ch[u][d])
    {
        memset(ch[sz],0,sizeof(ch[sz]));
    ch[u][d]=sz++;
    }
    else{
            int ji=ch[u][d];
        if(value[ji]==-1){flag=false;break;}
    }
    u=ch[u][d];
}
value[u]=-1;
}

bool cmp(string a,string b)
{
    return a.length()<b.length();
}

int main(){
    ios_base::sync_with_stdio(false);
int t,n;string str;
cin>>t;
while(t--)
{
    cin>>n;init();
for(int i=0;i<n;i++)
{
    cin>>ss[i];
}
sort(ss,ss+n,cmp);
for(int i=0;i<n;i++)
{
    insertstr(ss[i]);
    if(!flag)break;
}
if(flag)cout<<"YES"<<endl;
else cout<<"NO"<<endl;
}
return 0;}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值