HDU 2795 简单线段树问题

传送门

Problem Description
At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that’s why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.

Input
There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.

Output
For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can’t be put on the billboard, output “-1” for this announcement.

Sample Input

3 5 5
2
4
3
3
3

Sample Output

1
2
1
3
-1

题意: 在一个 H * W 的广告牌上贴公告,每个公告 1 * w。公告从最上端往下贴,层数从上往下递增,输出每个公告可以贴在第几层,如果公告贴不下则输出-1。
题解: 可能我太笨了,刚学线段树的这阶段,发现自己很难把题目和线段树联系起来,就是有人告诉我这是线段树问题,我也拿着模板,但我不知道要怎么下手。然后这里其实广告牌上的每一层,就对应树的每片叶子,每层的剩余宽度(因为贴公告会占位置)就是叶子上的值。要做的其实就是单点修改,每个公告尽量地往左子树贴,贴上以后对应叶子的值也要相应减少。

#include<iostream>
#include<algorithm>
using namespace std;
const int N = 200005;

int h, w, n, x;
int tree[N << 2];
void build(int p, int l, int r){
    tree[p] = w;
    if(l==r)	return;
    int mid = (l + r) >> 1;
    build(p << 1, l, mid);
    build(p << 1 | 1, mid + 1, r);
}

int update(int p, int l, int r, int board){
	if(l == r){
        tree[p] -= board;
        return l;
    }
    int mid = (l + r) >> 1;
    int ret;
	if(tree[p<<1] >= board)
        ret = update(p << 1, l, mid, board);
	else
        ret = update(p << 1 | 1, mid + 1, r, board);
    tree[p] = max(tree[p << 1], tree[p << 1 | 1]);
    return ret;
}

int main(){
    while(~scanf("%d%d%d", &h, &w, &n)){
        if(h > n)    h = n;
        build(1, 1, n);
        while (n--){
            scanf("%d", &x);
			if(tree[1] < x)
                printf("-1\n");
            else
                printf("%d\n", update(1, 1, h, x));
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值