大背包的解决方案

Problem Description

Given a set of n items, each with a weight w[i] and a value v[i], determine a way to choose the items into a knapsack so that the total weight is less than or equal to a given limit B and the total value is as large as possible. Find the maximum total value. (Note that each item can be only chosen once).

Input

The first line contains the integer T indicating to the number of test cases.

For each test case, the first line contains the integers n and B.

Following n lines provide the information of each item.

The i-th line contains the weight w[i] and the value v[i] of the i-th item respectively.

1 <= number of test cases <= 100

1 <= n <= 500

1 <= B, w[i] <= 1000000000

1 <= v[1]+v[2]+...+v[n] <= 5000

All the inputs are integers.

Output

For each test case, output the maximum value.

Sample Input

15 1512 42 21 14 101 2

Sample Output

15

总之起初看了这个问题感觉一脸懵逼,不过有了思路以后也是很好理解。01背包的第二重循环是从总重量遍历到该物品的重量,而这个题目里面物品的重量是很大的,用循环会超时,所以不妨把价值和重量换一下试试。因为价值v的值小嘛。也就是说,我们要求求一下dp[i][j]前i件物品价值为j的时候至少需要多重的背包。然后最后通过比较这些价值对应的背包重量和所给的背包重量来确定价值。嗯,就是转换了思路哈。
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
#define INF 0x3f3f3f3f
const int maxn = 550;
int w[maxn], v[maxn];
int dp[5500];
int main()
{
    int T, n, B;

    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&n,&B);
        int sumv = 0;
        for(int i = 1; i <= n; i++)
        {
            scanf("%d%d",&w[i],&v[i]);
            sumv += v[i];
        }
        memset(dp,INF,sizeof(dp));//因为下面要找最小值
        dp[0]=0;
        for(int i = 1; i <= n; i++)
        {
            for(int j = sumv; j >= v[i]; j--)
            {
                dp[j] = min(dp[j],dp[j-v[i]]+w[i]);//注意求的是该价值至少需要多重的背包

            }
        }
        for(int i = sumv; i >= 0; i--)
        {
            if(dp[i] <= B)
            {
                printf("%d\n",i);
                break;
            }
        }

    }
    return 0;

}
寻寻觅觅,冷冷清清,凄凄惨惨戚戚。
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值