HDU 1058 Humble Numbers

Question:
Description
A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, … shows the first 20 humble numbers.

Write a program to find and print the nth element in this sequence
Input
The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.
Output
For each test case, print one line saying “The nth humble number is number.”. Depending on the value of n, the correct suffix “st”, “nd”, “rd”, or “th” for the ordinal number nth has to be used like it is shown in the sample output.
Sample Input
1
2
3
4
11
12
13
21
22
23
100
1000
5842
0
Sample Output
The 1st humble number is 1.
The 2nd humble number is 2.
The 3rd humble number is 3.
The 4th humble number is 4.
The 11th humble number is 12.
The 12th humble number is 14.
The 13th humble number is 15.
The 21st humble number is 28.
The 22nd humble number is 30.
The 23rd humble number is 32.
The 100th humble number is 450.
The 1000th humble number is 385875.
The 5842nd humble number is 2000000000.
题目大意:一个数的素因子中只含2,3,5,7的数叫做humble number,求出第几个数humble number是多少。
解题思路:用数组来保存这些数,先把1放入,分别用,2,3,5,7乘以a[1],选取4个答案中最小的一个并保存,再将选取的这个数是由哪一个数乘以a[1]得到,将其乘以a数组的后一位(例如:第一个选取2,则变为,2*a[2],3*a[1],5*a[1],7*a[1],以此类推)
(http://acm.hust.edu.cn/vjudge/contest/125402#problem/F)

#include <iostream>
#include <cstdio>
using namespace std;
typedef long long LL;
LL a[5845];
int main()
{
    int t2=1,t3=1,t5=1,t7=1;
    a[1]=1;
    int  h=1;
    while(h<=5843)
    {
        LL tp;
        tp=min(min(2*a[t2],3*a[t3]),min(5*a[t5],7*a[t7]));
        a[++h]=tp;
        if(tp==2*a[t2])
            t2++;
        if(tp==3*a[t3])
            t3++;
        if(tp==5*a[t5])
            t5++;
        if(tp==7*a[t7])
            t7++;
    }
    int n,ncase=0;
    while(~scanf("%d",&n),n)
    {
        printf("The %d",n);
        if(n%10==1&&n%100!=11)     //输出格式有点复杂
            printf("st ");
        else if(n%10==2&&n%100!=12)
            printf("nd ");
        else if(n%10==3&&n%100!=13)
            printf("rd ");
        else printf("th ");
        printf("humble number is %lld.\n",a[n]);
    }
}

体会:做此类题开始想不到方法,但要善于变通

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值