POJ 2218 Does This Make Me Look Fat?

Does This Make Me Look Fat?

Description

As the host of a popular daytime television talk show, you are working through the details of an upcoming episode on dieting. Your guest is the controversial Dr. Kevorkian, who has recently invented his own weight-loss plan, "Do You Want To Diet?" that guarantees to reduce your body weight by 1 pound every day. 

You have a number of dieters scheduled to be on the show who have all been using Dr. Kevorkian?s new plan. You want to make the episode more dramatic by introducing your guests in decreasing order of their weights on the day of the show. The problem is that the forms you had them fill out only requested the following information: Name, Days on the diet, Weight at start of diet. Hopefully you can dredge up those long-forgotten math skills before the filming time tonight!

Input

Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets. 

A single data set has 3 components: 
  1. Start line - A single line, "START" 
  2. Dieter list - A series of 1 to 10 (inclusive) single lines consisting of three fields, with each field separated from the others by a single space: 
    • Name - The dieter?s first name. This will be a text string containing 1 to 20 (inclusive) alphanumeric characters (no spaces). 
    • Days On Diet - The number of days the dieter has been on the "Do You Want To Diet" as of the day of the talk show. This will be a non-zero positive integer strictly less than 1000. 
    • Starting Weight - The weight, in pounds, of the dieter just before starting the diet. This will be a non-zero positive integer strictly less than 10,000.

  3. End line - A single line, "END"

Here are some facts that may be useful: 
  • All dieters lost exactly 1 pound every day they were on the diet, as advertised. 
  • Nobody stayed on the diet long enough to weigh less than 1 pound at the time of the show. 
  • All dieters in a given input set will have different weights on the day of the show. 
  • All dieters in a given input set will have different names.

Output

For each input data set, there will be exactly one output set, and there will be exactly one blank line separating output sets. 

A single output set consists of a series of lines, each containing the Name of one of the dieters from the Dieter list. The list will be sorted in descending order according to weight at the time of the TV show. All dieters must be listed.

Sample Input

START
Joe 10 110
END
START
James 100 150
Laura 100 140
Hershey 100 130
END
START
Hershey0 1 5
Hershey2 1 3
Hershey1 1 4
Hershey3 1 2
END

Sample Output

Joe

James
Laura
Hershey

Hershey0
Hershey1
Hershey2
Hershey3
题目大意:有一个专家发明了一个减肥食谱,它可以让人每天减肥1磅。给出一些使用这些食谱的人的姓名、使用时间以及使用食谱之前的重量,按目前体重从高到低的顺序输出这些人的名字。

解题思路:使用结构体存储每个减肥者的信息,按照体重减去天数自大到小排列即可。

代码如下:

#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

typedef struct{
	char name[25];
	int day;
	int weight;
}dieter;

dieter dtr[15];

int cmp(dieter a,dieter b)
{
	return a.weight - a.day > b.weight - b.day;
}

int main()
{
	int i,j,k;
	char opt1[10],opt2[10];
	while(scanf("%s",opt1) != EOF && strcmp("START",opt1) == 0){
		for(i = 0;i < 11;i++){
			scanf("%s",dtr[i].name);
			if(strcmp(dtr[i].name,"END") == 0)
				break;
			scanf("%d %d",&dtr[i].day,&dtr[i].weight);
		}
		sort(dtr,dtr + i,cmp);
		for(j = 0;j < i;j++)
			printf("%s\n",dtr[j].name);
		printf("\n");
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值