POJ 2155 Matrix(二维树状数组)

Matrix

Description

Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N). 

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a '0' then change it into '1' otherwise change it into '0'). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions. 

1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2). 
2. Q x y (1 <= x, y <= n) querys A[x, y]. 

Input

The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case. 

The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2 y2", which has been described above. 

Output

For each querying output one line, which has an integer representing A[x, y]. 

There is a blank line between every two continuous test cases. 

Sample Input

1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1

Sample Output

1
0
0
1
题目大意:给出一个只由0和1构成的矩阵,初始时矩阵元素全为0。我们可以对矩阵进行取反操作,即将1变为0或将0变为1。现在给出取反操作的左上角元素与右下角元素的坐标,要求对于每次查询操作,输出对应位置元素的值。

解题思路:对于每次取反操作,我们只需在树状数组中更新4个值,分别是(x1,y1),(x2 + 1,y1),(x1,y2 + 1),(x2 + 1,y2 + 1),查询时只需判断sum(x,y)是否为偶数即可,证明如下


假设插入(x1,y1),(x2 + 1,y1),(x1,y2 + 1),(x2 + 1,y2 + 1)四个值,查询(x,y),如上图所示。

当(x,y)属于1,2,3,4或7这5个区域时,计算sum(x,y)不受插入的影响;

当(x,y)属于第5个区域时,sum(x,y)会受到(x1,y1)的影响,sum(x,y)会增加1,更改正确;

当(x,y)属于第6个区域时,sum(x,y)会受到(x1,y1)和(x2 + 1,y1)的影响,sum(x,y)会比之前增加2,结果不受影响,更改正确;

当(x,y)属于第8个区域时,sum(x,y)会受到(x1,y1)和(x1,y2 + 1)的影响,sum(x,y)会比之前增加2,结果不受影响,更改正确;

当(x,y)属于第9个区域时,sum(x,y)会受到(x1,y1),(x2 + 1,y1),(x1,y2 + 1)和(x2 + 1,y2 + 1)的影响,sum(x,y)会比之前增加4,结果不受影响,更改正确。

PS:以上图片及证明均来自论文《浅谈信息学竞赛中的“0”和“1”》

代码如下:

#include <algorithm>
#include <cctype>
#include <climits>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <map>
#include <queue>
#include <set>
#include <stack>
#include <vector>
#define EPS 1e-6
#define INF INT_MAX / 10
#define LL long long
#define MOD 100000000
#define PI acos(-1.0)
using namespace std;

const int maxn = 1005;
int bit[maxn][maxn];
int n;
int sum(int posx,int posy)
{
    int s = 0;
    int x = posx,y = posy;
    while(x > 0){
        while(y > 0){
            s += bit[x][y];
            y -= y & -y;
        }
        x -= x & -x;
        y = posy;
    }
    return s;
}

void add(int posx,int posy,int val)
{
    int x = posx,y = posy;
    while(x <= n){
        while(y <= n){
            bit[x][y] += val;
            y += y & -y;
        }
        x += x & -x;
        y = posy;
    }
}

int main()
{
    int t,m,a,b,c,d;
    char opt[2];
    scanf("%d",&t);
    while(t--){
        scanf("%d %d",&n,&m);
        memset(bit,0,sizeof(bit));
        while(m--){
            scanf("%s",opt);
            if(opt[0] == 'C'){
                scanf("%d %d %d %d",&a,&b,&c,&d);
                add(a,b,1);
                add(c + 1,b,1);
                add(a,d + 1,1);
                add(c + 1,d + 1,1);
            }
            if(opt[0] == 'Q'){
                scanf("%d %d",&a,&b);
                printf("%d\n",sum(a,b) % 2 ? 1 : 0);
            }
        }
        if(t)
            printf("\n");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值