【中兴交换机MC-LAG配置】

主设备配置如下:

Keepalive链路

interface smartgroup1023   //用作MC-LAG的Keepalive链路接口
  switch attribute disable
yes
  description For_Keepalived
exit

interface xgei-0/1/1/47
  switch attribute disable
yes
  description For_Keepalived
exit

interface xgei-0/1/1/48
  switch attribute disable
yes
  description For_Keepalived
exit

smartgroup fast-switch 1023 enable   //开启smartgroup口快速切换功能

lacp
  interface smartgroup1023
    lacp mode 802.3ad
    lacp fast respond    //lacp快速收敛 
  exit
  interface xgei-0/1/1/47
    smartgroup 1023 mode active
  exit
  interface xgei-0/1/1/48
    smartgroup 1023 mode active
  exit
exit

ip vrf keepalive 
  rd 1:1
    address-family ipv4
  exit 
exit

interface smartgroup1023    //配置keepalive链路的三层接口地址
 ip vrf forwarding keepalive
 ip address 1.1.1.1 255.255.255.252
exit

samgr
  track zte interface smartgroup1023
exit

Peer-Link链路

interface smartgroup1024
  description For_PeerLink
exit

interface xlgei-0/1/1/53
  description For_PeerLink
exit

interface xlgei-0/1/1/54
  description For_PeerLink
exit

smartgroup fast-switch 1024 enable   //开启smartgroup口快速切换功能

lacp
  interface smartgroup1024
    lacp mode 802.3ad
    lacp fast respond
    exit
  interface xlgei-0/1/1/53
    smartgroup 1024 mode active
    exit 
  interface xlgei-0/1/1/54
    smartgroup 1024 mode active
    exit
  exit
  lacp peer-link smartgroup1024    // 将smartgroup1024设置为peerlink
    exit
exit

switchvlan-configuration
  interface smartgroup1024
    switchport mode trunk
    switchport trunk vlan xx      //peer-link透传下行业务VLAN
    switchport trunk native vlan 4094   //将ICCP通道使用的VLAN作为本地vlan
    acceptable frame types tag
  exit
exit

iccp peerlink vlan 4094

interface vlan 4094
  ip address 1.1.1.5 255.255.255.252
exit

MC-LAG配置

mpls ldp instance 1 
  router-id 1.1.1.5
exit

redundancy interchassis group 1   //配置RG组,用于TOR链路同步mac表项,每一个RG组绑定10个SG。
  peer 1.1.1.6
  apply mac        //表明这个rg会用于同步mac
  apply arp        //表明这个rg会用于同步arp
  apply nd        //表明这个rg会用于同步nd
  apply stp        //表明这个rg会用于同步stp
exit

redundancy interchassis group 2    //配置RG组,用于TOR链路同步mac表项,每一个RG组绑定10个SG。
  peer 1.1.1.6
  apply mac        //表明这个rg会用于同步mac
  apply arp        //表明这个rg会用于同步arp
  apply nd        //表明这个rg会用于同步nd
  apply stp        //表明这个rg会用于同步stp
exit
///若干个

lacp
  mc-lag priority 120 //根据优先级协商设备级的主备,优先级小的为主,peerlink断链时,备设备进行退避,建议主为120,备为150
  mc-lag ipv4 source 1.1.1.1 destination 1.1.1.2 vrf keepalive
  mc-lag track zte peer-type      //绑定track ,用于退避之前检测keepalive链路
  mc-lag exempt smartgroup1023   //配置退避豁免口,退避时不会将keepalive端口down掉
  mc-lag reload-delay-up 480    //重启上电后端口延时UP时间配置,默认是480s
exit

mc-lag业务成员口配置

interface smartgroup11
  description connect-to-server1
exit

interface smartgroup12
  description connect-to-server2
exit

lacp
  interface smartgroup11
    lacp mode 802.3ad 
    lacp fast respond
  exit
  interface xgei-0/1/1/1
    smartgroup 11 mode active
  exit
  interface smartgroup12
    lacp mode 802.3ad 
    lacp fast respond
  exit
  interface xgei-0/1/1/2
    smartgroup 11 mode active
  exit
exit

lacp
  interface smartgroup11    ///若干个
    mc-lag mode force-master      //设置为双主模式  
    mc-lag ipv4 source 1.1.1.1 destination 1.1.1.2 vrf keepalive
    mc-lag priority 120        //优先级值越小为主设备
    mc-lag roid 11 node-id 1   //两台设备同一个mc-lag的 roid值要一致,node-id值要不一样
    mc-lag sys-id 0000.5960.0011 sys-priority 111   //两台设备同一个mc-lag的sys-id和sys-priority 需要一致,为100+SG编号
  exit
  interface smartgroup12     ///若干个
    mc-lag mode force-master    //设置为双主模式  
    mc-lag ipv4 source 1.1.1.1 destination 1.1.1.2 vrf keepalive
    mc-lag priority 120      //优先级值越小为主设备
    mc-lag roid 12 node-id 1   //两台设备同一个mc-lag的 roid值要一致,node-id值要不一样
    mc-lag sys-id 0000.5960.0012 sys-priority 112    //两台设备同一个mc-lag的sys-id和sys-priority 需要一致,为100+SG编号
  exit 
exit

icbg sg11       //配置同步使用的ICBG组,用于指定表项同步的接口
  bind interface smartgroup11    //需要同步mac的接口
  bind rg 1        //绑定同步的rg
  bind slave-interface smartgroup1024   //绑定peerlink链路
    group-backup-interval 5  //定时同步间隔,最小是5分钟,默认是10分钟
exit

icbg sg12        //配置同步使用的ICBG组,用于指定表项同步的接口
  bind interface smartgroup12   //需要同步mac的接口
  bind rg 1        //绑定同步的rg
  bind slave-interface smartgroup1024  //绑定peerlink链路
    group-backup-interval 5  //定时同步间隔,最小是5分钟,默认是10分钟
exit

switchvlan-configuration
    interface smartgroup11
    switchport mode access
    switchport access vlan xx
    exit
    interface smartgroup12
    switchport mode access
    switchport access vlan xx
    exit
exit

生成树配置

spantree      //配置VSTP
    enable 
    mode rstp
    tc-guard enable
    vstp enable     
    interface smartgroup11  //与服务器对接的端口设置为边缘端口                                            
        edged-port enable
    exit
    interface smartgroup12  //与服务器对接的端口设置为边缘端口                                            
        edged-port enable
    exit
    ///若干个
    interface smartgroup1024  //加入MC-LAG的PEER-LINK设置为内部端口
        internal-port enable 
    exit 
    interfacesmartgroup 1  //上行接口disable
        disable 
    exit
exit

三层逃生

interface vlan4090
  description For_Service-Escape
  ip address 192.168.1.1 255.255.255.252
exit

switchvlan-configuration
  interface smartgroup1024
    switchport mode trunk
    switchport trunk vlan add 4090
  exit
exit
互相指相关地址段静态即可,注意优先级;
ip route 0.0.0.0 0.0.0.0 vlan4090 192.168.1.2 250

=======================================================

备设备配置如下:

Keepalive链路

interface smartgroup1023   //用作MC-LAG的Keepalive链路接口
  switch attribute disable
yes
  description For_Keepalived
exit

interface xgei-0/1/1/47
  switch attribute disable
yes
  description For_Keepalived
exit

interface xgei-0/1/1/48
  switch attribute disable
yes
  description For_Keepalived
exit

smartgroup fast-switch 1023 enable  //开启smartgroup口快速切换功能

lacp
  interface smartgroup1023
    lacp mode 802.3ad
    lacp fast respond    //lacp快速收敛
  exit
  interface xgei-0/1/1/47
    smartgroup 1023 mode active
  exit
  interface xgei-0/1/1/48
    smartgroup 1023 mode active
  exit
exit

ip vrf keepalive 
  rd 1:1
    address-family ipv4
  exit 
exit

interface smartgroup1023   //配置keepalive链路的三层接口地址
 ip vrf forwarding keepalive
 ip address 1.1.1.2 255.255.255.252
exit

samgr
  track zte interface smartgroup1023
exit

Peer-Link链路

interface smartgroup1024
  description For_PeerLink
exit

interface xlgei-0/1/1/53
  description For_PeerLink
exit

interface xlgei-0/1/1/54
  description For_PeerLink
exit

smartgroup fast-switch 1024 enable   //开启smartgroup口快速切换功能

lacp
  interface smartgroup1024
    lacp mode 802.3ad
    lacp fast respond
    exit
  interface xlgei-0/1/1/53
    smartgroup 1024 mode active
    exit 
  interface xlgei-0/1/1/54
    smartgroup 1024 mode active
    exit
  exit
  lacp peer-link smartgroup1024   // 将smartgroup1024设置为peerlink
    exit
exit

switchvlan-configuration
  interface smartgroup1024
    switchport mode trunk
    switchport trunk vlan xx   //peer-link透传下行业务VLAN
    switchport trunk native vlan 4094  //将ICCP通道使用的VLAN作为本地vlan
    acceptable frame types tag
  exit
exit

iccp peerlink vlan 4094

interface vlan 4094
  ip address 1.1.1.6 255.255.255.252
exit

MC-LAG配置

mpls ldp instance 1 
  router-id 1.1.1.6
exit

redundancy interchassis group 1  //配置RG组,用于TOR链路同步mac表项,每一个RG组绑定10个SG。
  peer 1.1.1.5
  apply mac        //表明这个rg会用于同步mac
  apply arp        //表明这个rg会用于同步arp
  apply nd        //表明这个rg会用于同步nd
  apply stp        //表明这个rg会用于同步stp
exit

redundancy interchassis group 2  //配置RG组,用于TOR链路同步mac表项,每一个RG组绑定10个SG。
  peer 1.1.1.5
  apply mac        //表明这个rg会用于同步mac
  apply arp        //表明这个rg会用于同步arp
  apply nd        //表明这个rg会用于同步nd
  apply stp        //表明这个rg会用于同步stp
exit
///若干个

lacp
  mc-lag priority 150  //根据优先级协商设备级的主备,优先级小的为主,peerlink断链时,备设备进行退避,建议主为120,备为150
  mc-lag ipv4 source 1.1.1.2 destination 1.1.1.1 vrf keepalive
  mc-lag track zte peer-type     //绑定track ,用于退避之前检测keepalive链路
  mc-lag exempt smartgroup1023  //配置退避豁免口,退避时不会将keepalive端口down掉
  mc-lag reload-delay-up 480   //重启上电后端口延时UP时间配置,默认是480s
exit

mc-lag业务成员口配置

interface smartgroup11
  description connect-to-server
exit 

lacp
  interface smartgroup11 
    lacp mode 802.3ad 
    lacp fast respond
  exit
  interface xgei-0/1/1/1 
    smartgroup 11 mode active
  exit
  interface smartgroup12
    lacp mode 802.3ad 
    lacp fast respond
  exit
  interface xgei-0/1/1/2 
    smartgroup 12 mode active
  exit
exit

lacp
  interface smartgroup11            ///若干个
    mc-lag mode force-master        //设置为双主模式  
    mc-lag ipv4 source 1.1.1.2 destination 1.1.1.1 vrf keepalive
    mc-lag priority 150            //优先级值越小为主设备
    mc-lag roid 11 node-id 2        两台设备同一个mc-lag的 roid值要一致,node-id值要不一样
    mc-lag sys-id 0000.5960.0011 sys-priority 111  //两台设备同一个mc-lag的sys-id和sys-priority 需要一致,为100+SG编号
  exit
  interface smartgroup12            ///若干个
    mc-lag mode force-master       //设置为双主模式  
    mc-lag ipv4 source 1.1.1.2 destination 1.1.1.1 vrf keepalive
    mc-lag priority 150          //优先级值越小为主设备
    mc-lag roid 11 node-id 2    //两台设备同一个mc-lag的 roid值要一致,node-id值要不一样
    mc-lag sys-id 0000.5960.0012 sys-priority 112  //两台设备同一个mc-lag的sys-id和sys-priority 需要一致,为100+SG编号
  exit 
exit

icbg sg11        //配置同步使用的ICBG组,用于指定表项同步的接口
  bind interface smartgroup11  //需要同步mac的接口
  bind rg 1    //绑定同步的rg
  bind slave-interface smartgroup1024  //绑定peerlink链路
    group-backup-interval 5  //定时同步间隔,最小是5分钟,默认是10分钟
exit

icbg sg12        //配置同步使用的ICBG组,用于指定表项同步的接口
  bind interface smartgroup12  //需要同步mac的接口
  bind rg 1   //绑定同步的rg
  bind slave-interface smartgroup1024      //绑定peerlink链路
    group-backup-interval 5  //定时同步间隔,最小是5分钟,默认是10分钟
exit

switchvlan-configuration
    interface smartgroup11
    switchport mode access
    switchport access vlan xx
    exit
    interface smartgroup12
    switchport mode access
    switchport access vlan xx
    exit
exit

生成树配置

spantree      //配置VSTP
    enable 
    mode rstp
    tc-guard enable
    vstp enable     
    interface smartgroup11  //与服务器对接的端口设置为边缘端口                                            
        edged-port enable
    exit
    interface smartgroup12  //与服务器对接的端口设置为边缘端口                                            
        edged-port enable
    exit
    ///若干个

    interface smartgroup1024  //加入MC-LAG的PEER-LINK设置为内部端口
        internal-port enable 
    exit 
    interfacesmartgroup 1  //上行接口disable
        disable 
    exit
exit

三层逃生

interface vlan4090
  description For_Service-Escape
  ip address 192.168.1.2 255.255.255.252
exit

switchvlan-configuration
  interface smartgroup1024
    switchport mode trunk
    switchport trunk vlan add 4090
  exit
exit
互相指相关地址段静态即可,注意优先级;
ip route 0.0.0.0 0.0.0.0 vlan4090 192.168.1.1 250
  • 5
    点赞
  • 57
    收藏
    觉得还不错? 一键收藏
  • 2
    评论
中兴2826S系列交换机常用配置命令 发表于 2009-12-24 22:10:26 以下命令只包含一些常用的命令[//]后面的表示注解,即说明本条命令所产生的意义。 以下命令适用于中兴ZXR10 2609/2818S/2826S/2852S系列交换机 命令如下: 创建VLAN命令: view sourceprint?1 set vlan 10 enable ///创建vlan 2 set vlan 10 add port 1-24 untag ///在创建的vlan内添加用户端口 3 set vlan 10 add port 25 tag ///把级联端口添加到vlan10中,需打tag标签,即为trunk端口。 4 set port 1-24 pvid 10 ///把添加到vlan10的用户端口,pvid至vlan10中。交换机用户端口必须在所添加的vlan中做此项命令。(默认的pvid为vlan10) 删除vlan命令如下: view sourceprint?1 set vlan 10 delete port 1-24 ///删除用户端口 2 set vlan 10 delete port 25 ///删除级联端口 3 set vlan 10 disable ///删除vlan 4 set port 1-24 pvid 1 ///恢复默认设置,该项命令必须添加,不然还会在show running-config信息中显示 5 set port 1-24 pvid 10的信息,会导致vlan用户使用不正常 ENABLE密码配置: view sourceprint?1 zte>enable //进入全局配置模式 2 password:***** //输入进入全局配置模式的密码,缺省没有密码 3 zte(cfg)#adminpass zxr10 //配置进入全局配置模式的密码为zxr10 TELNET 用户名密码配置(为了便于对设备的维护,有时需要修改登录用户名或密码,配置如下:) view sourceprint?1 zte(cfg)#create user zxr10 //创建名为zxr10的用户 2 zte(cfg)#loginpass zxr10 //设置登录密码为zxr10 3 zte(cfg)#show user //显示telnet登录用户信息和当前用户名

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值