poj3349 Snowflake Snow Snowflakes


Snowflake Snow Snowflakes
Time Limit: 4000MS Memory Limit: 65536K
Total Submissions: 38288 Accepted: 10031

Description

You may have heard that no two snowflakes are alike. Your task is to write a program to determine whether this is really true. Your program will read information about a collection of snowflakes, and search for a pair that may be identical. Each snowflake has six arms. For each snowflake, your program will be provided with a measurement of the length of each of the six arms. Any pair of snowflakes which have the same lengths of corresponding arms should be flagged by your program as possibly identical.

Input

The first line of input will contain a single integer n, 0 < n ≤ 100000, the number of snowflakes to follow. This will be followed by n lines, each describing a snowflake. Each snowflake will be described by a line containing six integers (each integer is at least 0 and less than 10000000), the lengths of the arms of the snow ake. The lengths of the arms will be given in order around the snowflake (either clockwise or counterclockwise), but they may begin with any of the six arms. For example, the same snowflake could be described as 1 2 3 4 5 6 or 4 3 2 1 6 5.

Output

If all of the snowflakes are distinct, your program should print the message:
No two snowflakes are alike.
If there is a pair of possibly identical snow akes, your program should print the message:
Twin snowflakes found.

Sample Input

2
1 2 3 4 5 6
4 3 2 1 6 5

Sample Output

Twin snowflakes found.

已经用代码测试过了,数据非常的水qwq,水的你无法想象,我这里只说应该的做法。

这个题就是让你找两个同构,顺时针,或者逆时针相等就可以,比如说示例,第二个逆时针走就可以得到相同的数列,也就是不断的向左移动。顺时针自然就是向右移动了,譬如说1 2 3 4 5 6和3 4 5 6 1 2是相同的。雪花相同的首要条件就是数列的和相同,我们可以根据这个来建造哈希表,因为N最大为10W,所以和的种类不会超过10W,所以我们可以直接对10W取模。之后就是读入一个串,在哈希表中查找,如果有有相同的串就做一下标记,然后输出就可以啦。否则就压进去。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <cmath>
#include <vector>
#include <map>
using namespace std;
const int MAXN=100000+5;
const int mod=100000;
int n;

int panduan(int *a,int *b)
{
    int i,k;
    for(k=0; k<6; ++k)//顺时针判断
    {
        for(i=0; i<6; ++i)
        {
            if(a[i]!=b[(i+k)%6])break;
        }
        if(i==6) return 1;
    }
    for(k=0; k<6; ++k)//逆时针判断
    {
        for(i=0; i<6; ++i)
        {
            if(a[5-i]!=b[(i+k)%6])break;
        }
        if(i==6) return 1;
    }

    return 0;
}

struct node
{
    int p[7];
};
vector<node>head[MAXN];
int main()
{

    scanf("%d",&n);
    int i,j;
    int sum;
    int flag=1;
    node t;
    for(i=0; i<n; ++i)
    {
        sum=0;
        for(j=0; j<6; ++j)
        {
            scanf("%d",&t.p[j]);
            sum+=t.p[j];
        }
            int d=sum%mod;
            int l=head[d].size();
            for(j=0; j<l; ++j)
                if(panduan(head[d][j].p,t.p))
                {
                    flag=0;
                    goto xx;
                }
            head[d].push_back(t);
        }
xx:
    if(!flag)
    {
        for(i++; i<n; ++i)
            for(j=0; j<6; ++j)scanf("%*d");
    }
    if(flag)printf("No two snowflakes are alike.\n");
    else printf("Twin snowflakes found.\n");

    return 0;
}








  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值