hdu1728 关于bfs的理解

Description

  给定一个m × n (m行, n列)的迷宫,迷宫中有两个位置,gloria想从迷宫的一个位置走到另外一个位置,当然迷宫中有些地方是空地,gloria可以穿越,有些地方是障碍,她必须绕行,从迷宫的一个位置,只能走到与它相邻的4个位置中,当然在行走过程中,gloria不能走到迷宫外面去。令人头痛的是,gloria是个没什么方向感的人,因此,她在行走过程中,不能转太多弯了,否则她会晕倒的。我们假定给定的两个位置都是空地,初始时,gloria所面向的方向未定,她可以选择4个方向的任何一个出发,而不算成一次转弯。gloria能从一个位置走到另外一个位置吗?
 

Input

  第1行为一个整数t (1 ≤ t ≤ 100),表示测试数据的个数,接下来为t组测试数据,每组测试数据中, 
  第1行为两个整数m, n (1 ≤ m, n ≤ 100),分别表示迷宫的行数和列数,接下来m行,每行包括n个字符,其中字符'.'表示该位置为空地,字符'*'表示该位置为障碍,输入数据中只有这两种字符,每组测试数据的最后一行为5个整数k, x  1, y  1, x  2, y  2 (1 ≤ k ≤ 10, 1 ≤ x  1, x  2 ≤ n, 1 ≤ y  1, y  2 ≤ m),其中k表示gloria最多能转的弯数,(x  1, y  1), (x  2, y  2)表示两个位置,其中x  1,x  2对应列,y  1, y  2对应行。 
 

Output

  每组测试数据对应为一行,若gloria能从一个位置走到另外一个位置,输出“yes”,否则输出“no”。
 

Sample Input

    
    
2 5 5 ...** *.**. ..... ..... *.... 1 1 1 1 3 5 5 ...** *.**. ..... ..... *.... 2 1 1 1 3
 

Sample Output

    
    
no yes


真特么蛋疼    一开始我也是把这道题当成常规的  BFS  求最短路径  来写   WA了3发   百思不得其姐  bug怎么找都找不出来   无奈看了一下题解才恍然大悟

这么说吧    题目要求的是  从一个点到另一个点的最小拐弯数

假如说是常规的BFS  从一点到另一点  只能保证路径最短  拐弯数的多少和路径长短是毫无联系的

所以我们每次查找四个方向的时候  直接把一整条直线的grid全都压进队列   因为他们的拐弯数相同  优先级相同


ac code  感觉时间略长  有待优化   只能助于理解用


#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
#include <cmath>
#include <algorithm>

using namespace std;
int row,col,limit;
int st_x,st_y,en_x,en_y;
char mat[110][110];
bool vis[110][110];
int dx[]= {-1,0,1,0};
int dy[]= {0,-1,0,1};

struct node
{
    int x,y;
    int step;
    node(int _x,int _y,int _step):x(_x),y(_y),step(_step) {}
};

bool judge(int a,int b)
{
    return a>0&&a<=row&&b>0&&b<=col&&mat[a][b]=='.';
}

void bfs()
{
    queue<node> que;
    que.push(node(st_x,st_y,-2));
    vis[st_x][st_y]=true;
    while(!que.empty())
    {
        node temp=que.front();
        que.pop();
        int x=temp.x,y=temp.y;
        int step=temp.step+1;
        //printf("%d %d %d\n",x,y,step);
        if(x==en_x&&y==en_y&&step<=limit)
        {
            printf("yes\n");
            return ;
        }
        for(int i=0; i<4; i++)
        {
            int xx=x+dx[i];
            int yy=y+dy[i];
            while(judge(xx,yy))
            {
                if(!vis[xx][yy])
                {
                    vis[xx][yy]=true;
                    que.push(node(xx,yy,step));
                }
                xx+=dx[i];
                yy+=dy[i];
            }
        }
    }
    printf("no\n");
    return ;
}


int main()
{
    int test;
    scanf("%d",&test);
    while(test--)
    {
        scanf("%d%d",&row,&col);
        getchar();
        for(int i=1; i<=row; i++)
        {
            for(int j=1; j<=col; j++)
                scanf("%c",&mat[i][j]);
            getchar();
        }
        scanf("%d%d%d%d%d",&limit,&st_y,&st_x,&en_y,&en_x);
        memset(vis,false,sizeof vis);
        bfs();
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值