poj2785(4 Values whose Sum is 0)

Language:
4 Values whose Sum is 0
Time Limit: 15000MS Memory Limit: 228000K
Total Submissions: 19972 Accepted: 5953
Case Time Limit: 5000MS

Description

The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n .

Input

The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 2 28 ) that belong respectively to A, B, C and D .

Output

For each input file, your program has to write the number quadruplets whose sum is zero.

Sample Input

6
-45 22 42 -16
-41 -27 56 30
-36 53 -37 77
-36 30 -75 -46
26 -38 -10 62
-32 -54 -6 45

Sample Output

5

Hint

Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46),(-32, 30, -75, 77), (-32, -54, 56, 30).

Source

题目意思很简单明了,就是从四个数列中各取一个数,使四个数的和为0,求共有多少种方法?
可以直接的四个for循环,但是显然很不高效。把它们分成AB和CD再考虑,就可以快速求解。大致思路是把C、D中的数字枚举出来,排好序,为了使总和为0则需要从C、D中取出c+d=-a-b,可以用二分查找,时间复杂度为O(n^2logn)。
AC代码:
#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
#define maxn 4005
int A[maxn],B[maxn],C[maxn],D[maxn];
int CD[maxn*maxn];
int main()
{
    int n;
    scanf("%d",&n);
    for(int i=0;i<n;i++){
        scanf("%d%d%d%d",&A[i],&B[i],&C[i],&D[i]);
    }
    for(int i=0;i<n;i++){
        for(int j=0;j<n;j++){
            CD[i*n+j]=C[i]+D[j];
        }
    }
    sort(CD,CD+n*n);
    long long res=0;
    for(int i=0;i<n;i++){
        for(int j=0;j<n;j++){
            int cd=-(A[i]+B[j]);
            res+=upper_bound(CD,CD+n*n,cd)-lower_bound(CD,CD+n*n,cd);
        }
    }
    printf("%lld\n",res);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值