矩阵快速幂POJ-3070

51 篇文章 0 订阅
16 篇文章 0 订阅


Fibonacci
Time Limit: 1000MS
Memory Limit: 65536K
Total Submissions: 13406
Accepted: 9539

Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0
9
999999999
1000000000
-1

Sample Output

0
34
626
6875

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

.

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

.


拿这道题写一下矩阵快速幂的思想吧!



首先题目中这里已经给出了斐波那契的矩阵乘法转化为快速幂的公式与思想,那么我们就不能再用抵推式运算,因为数字过大会导致超时。

矩阵快速幂:

矩阵的快速幂与数字快速幂的思路完全一样。但要注意以下几点区别:

1.数字快速幂 ans初始为1   矩阵快速幂初始为E

2.数字快速幂传入数字,矩阵快速幂传入矩阵(结构体存储)-----乘法需要调用矩阵乘法(On^3)

51nod基础题也有一个,不过他没告诉用到矩阵快速幂,递推交了发,结果只是过了4%

#include <cstdio>
#include <cstdlib>
#include <algorithm>
#include <cstring>
#include <iostream>

using namespace std;

struct matrix{
	long long arr[3][3];
};
matrix base,ans;
matrix matrix_mulip(matrix a,matrix b)
{
    matrix tep;
    for(int i=1;i<=2;i++)
    {
        for(int j=1;j<=2;j++)
        {
            tep.arr[i][j]=0;
            for(int k=1;k<=2;k++)
            {
                tep.arr[i][j]=(tep.arr[i][j]+a.arr[i][k]*b.arr[k][j])%10000;
            }
        }
    }
    return tep;
}

void matrix_pow(matrix a,long long n)
{
    while(n)
    {
        if(n%2)
        {
            ans=matrix_mulip(ans,a);
        }
        a=matrix_mulip(a,a);
        n=n/2;
    }
}
int main()
{
    base.arr[1][1]=base.arr[1][2]=base.arr[2][1]=1;
    base.arr[2][2]=0;
    long long  n;
    while(~scanf("%lld",&n)&&n!=-1)
    {
        ans.arr[1][1]=ans.arr[2][2]=1;
        ans.arr[1][2]=ans.arr[2][1]=0;
        matrix_pow(base,n);
        cout<<ans.arr[1][2]%100000<<endl;
    }
    return 0;
}











  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值