POJ 3468 A Simple Problem with Integers 线段树区间更新 纯模板题

A Simple Problem with Integers
Time Limit: 5000MS Memory Limit: 131072K
Total Submissions: 94006 Accepted: 29291
Case Time Limit: 2000MS

Description

You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of Aa, Aa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of Aa, Aa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

24k纯模板

//poj 3468 A Simple Problem with Integers 线段树区间更新 
#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;
const int maxn=100000;
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
using namespace std;
long long sum[maxn<<2],add[maxn<<2];
void pushdown(int m,int rt)
{
    if(add[rt])
    {
    add[rt<<1]+=add[rt];
    add[rt<<1|1]+=add[rt];
    sum[rt<<1]+=(m-(m>>1))*add[rt];
    sum[rt<<1|1]+=(m>>1)*add[rt];
    add[rt]=0;
    }
}

void pushup(int rt)
{
    sum[rt]=sum[rt<<1]+sum[rt<<1|1];

}

void build(int l,int r,int rt)
{
    sum[rt]=0;
    add[rt]=0;
    if(l==r)
    {
        int c;
        scanf("%I64d",&sum[rt]);
        return ;
    }
    int m=(l+r)>>1;
    build(lson);
    build(rson);
    pushup(rt);

}

void update(int L,int R,long long c,int l,int r,int rt)
{
    if(L<=l&&R>=r)
    {
        sum[rt]+=(r-l+1)*c;
        add[rt]+=c;
        return;
    }
    int m=(l+r)>>1;
    pushdown(r-l+1,rt);
    if(L<=m) update(L,R,c,lson);
    if(R>m)  update(L,R,c,rson);
    pushup(rt);

}

long long query(int L,int R,int l,int r,int rt)
{
    if(L<=l&&R>=r)
    {
        return sum[rt];

    }
    int m=(l+r)>>1;
    pushdown(r-l+1,rt);
    long long ans=0;
    if(L<=m) ans+=query(L,R,lson);
    if(R>m)  ans+=query(L,R,rson);
    return ans;
}

int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m))
    {
        memset(add,0,sizeof(add));
        memset(sum,0,sizeof(sum));
        build(1,n,1);
        while(m--)
        {
            char a[10];
            cin>>a;
            if(a[0]=='Q')
            {
                long long  s,t;
                scanf("%I64d%I64d",&s,&t);
                printf("%I64d\n",query(s,t,1,n,1));
                continue;
            }
            if(a[0]=='C')
            {
                long long  s,t,c;
                scanf("%I64d%I64d%I64d",&s,&t,&c);
                update(s,t,c,1,n,1);
            }
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值