BestCoder Round #85

sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 120    Accepted Submission(s): 66


Problem Description
Given a sequence, you're asked whether there exists a consecutive subsequence whose sum is divisible by m. output YES, otherwise output NO
 

Input
The first line of the input has an integer T ( 1T10 ), which represents the number of test cases.
For each test case, there are two lines:
1.The first line contains two positive integers n, m ( 1n100000 , 1m5000 ).
2.The second line contains n positive integers x ( 1x100 ) according to the sequence.
 

Output
Output T lines, each line print a YES or NO.
 

Sample Input
  
  
2 3 3 1 2 3 5 7 6 6 6 6 6
 

Sample Output
  
  
YES NO

xjb算法 认真签到是一种态度。。。
题意:给定一个数列,求是否存在连续子列和为m的倍数,存在输出YES,否则输出NO

#include <iostream>
#include <string.h>
using namespace std;
const int maxn=100005;
int num[maxn];
int flag,k;
long long a,b,sum;
void dfs(int q)
{
	if(q>a) return;
	sum+=num[q];
	if(sum%b==0&&q<=a)
	{
		flag=1;
		return;
	}
	q++;
	dfs(q);
}
int main()
{
    ios::sync_with_stdio(false);
	int n;
	cin>>n;
	while(n--)
	{
		memset(num,0,sizeof(num));
		cin>>a>>b;
		for(int i=0;i<a;i++)
		{
			cin>>num[i];
		}
		flag=0;
		for(k=0;k<a;k++)
		{
			sum=0;
			dfs(k);
			if(flag)
			break;
		}
		if(flag)
		cout<<"YES"<<endl;
		else 
		cout<<"NO"<<endl;
		
	}
}


domino

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 132    Accepted Submission(s): 77


Problem Description
Little White plays a game.There are n pieces of dominoes on the table in a row. He can choose a domino which hasn't fall down for at most k times, let it fall to the left or right. When a domino is toppled, it will knock down the erect domino. On the assumption that all of the tiles are fallen in the end, he can set the height of all dominoes, but he wants to minimize the sum of all dominoes height. The height of every domino is an integer and at least 1.
 

Input
The first line of input is an integer T ( 1T10 )
There are two lines of each test case.
The first line has two integer n and k, respectively domino number and the number of opportunities.( 2k,n100000 )
The second line has n - 1 integers, the distance of adjacent domino d, 1d100000
 

Output
For each testcase, output of a line, the smallest sum of all dominoes height
 

Sample Input
   
   
1 4 2 2 3 4
 

Sample Output
   
   
9
 

#include <iostream>
#include <algorithm>
using namespace std;
int i,j,k;
int n,m;
long long s[100005];
int main()
{

   int t;cin>>t;
   while(t--){
     cin>>n>>m;
      long long sum=n;
      for(i=1;i<n;i++){
        cin>>s[i];
      }
      sort(s+1,s+n);
      for(i=1;i<=n-m;i++){
        sum+=s[i];
      }
       cout<<sum<<endl;
   }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值