1048 Find Coins

1048 Find Coins (25 point(s))

Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she could only use exactly two coins to pay the exact amount. Since she has as many as 10​5​​ coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find two coins to pay for it.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (≤10​5​​, the total number of coins) and M (≤10​3​​, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers no more than 500. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the two face values V​1​​ and V​2​​ (separated by a space) such that V​1​​+V​2​​=M and V​1​​≤V​2​​. If such a solution is not unique, output the one with the smallest V​1​​. If there is no solution, output No Solution instead.

Sample Input 1:

8 15
1 2 8 7 2 4 11 15

Sample Output 1:

4 11

Sample Input 2:

7 14
1 8 7 2 4 11 15

Sample Output 2:

No Solution

这题有两种方法:首先是散列法:

题目告诉我们m的最大值是1000,每个硬币不超过500,所以可以用散列的方法,但是大小不应该仅仅是500,应该是1000,;因为在匹配的时候,m-hash[i],可能会超过500,那会产生段错误(易错,改了这个,我才能通过!!!)。

#include <cstdio>
#include <algorithm>
#define Maxsize 100010
using namespace std;

int main()
{
	
	int	i,n,m,a;       //n:the total number of coins m:the amount of money Eva has to pay
	int hash[1010]={0};
	scanf("%d%d",&n,&m);
	for(i=0;i<n;i++)
	{
		scanf("%d",&a);
		hash[a]++;
	}

	for(i=0;i<=m/2;i++)
	{
		hash[i]--;
		hash[m-i]--;
		if(hash[i]>=0 && hash[m-i]>=0)      //偶数可能两个数相等。
		{
			printf("%d %d",i,m-i);
			return 0;
		}
	}
	printf("No Solution");
	


}

方法二:二分法

比较简单:直接贴代码啦

#include <cstdio>
#include <algorithm>
#define Maxsize 100010
using namespace std;

//在数组a[i]~a[j]中用二分法查找x,找到返回其位置,否则返回-1;
int binarySearch(int a[],int i,int j,int x)
{
	int mid;
	while(i<=j)
		{
			mid=(i+j)/2;
			if(a[mid]==x)
			{
				return mid;
			}
			else if(a[mid]>x)
			{
				j=mid-1;
			}
			else
			{
				i=mid+1;
			}
		}

	return -1;
}

int main()
{
	
	int	i,temp,n,m,coin[Maxsize];       //n:the total number of coins m:the amount of money Eva has to pay

	scanf("%d%d",&n,&m);
	for(i=0;i<n;i++)
	{
		scanf("%d",&coin[i]);
	
	}
	sort(coin,coin+n);

	for(i=0;coin[i]<=m/2;i++)
	{
	
		temp=binarySearch(coin,i+1, n-1 ,m-coin[i]);
		if(temp>0)
		{
			printf("%d %d",coin[i],m-coin[i]);
			return 0;
		}
	}
	printf("No Solution");
	
	return 0;

}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值