拯救007

Saving James Bond - Easy Version
挺有意思的一个题目,考察图的BFS或者DFS,这里我用DFS,写起来比较容易。
This time let us consider the situation in the movie “Live and Let Die” in which James Bond, the world’s most famous spy, was captured by a group of drug dealers. He was sent to a small piece of land at the center of a lake filled with crocodiles. There he performed the most daring action to escape – he jumped onto the head of the nearest crocodile! Before the animal realized what was happening, James jumped again onto the next big head… Finally he reached the bank before the last crocodile could bite him (actually the stunt man was caught by the big mouth and barely escaped with his extra thick boot).

Assume that the lake is a 100 by 100 square one. Assume that the center of the lake is at (0,0) and the northeast corner at (50,50). The central island is a disk centered at (0,0) with the diameter of 15. A number of crocodiles are in the lake at various positions. Given the coordinates of each crocodile and the distance that James could jump, you must tell him whether or not he can escape.

Input Specification:
Each input file contains one test case. Each case starts with a line containing two positive integers N (≤100), the number of crocodiles, and D, the maximum distance that James could jump. Then N lines follow, each containing the (x,y) location of a crocodile. Note that no two crocodiles are staying at the same position.

Output Specification:
For each test case, print in a line “Yes” if James can escape, or “No” if not.

Sample Input 1:
14 20
25 -15
-25 28
8 49
29 15
-35 -2
5 28
27 -29
-8 -28
-20 -35
-25 -20
-13 29
-30 15
-35 40
12 12
Sample Output 1:
Yes
Sample Input 2:
4 13
-12 12
12 12
-12 -12
12 -12
Sample Output 2:
No

def DFS(L,D,s,visited=[]):
	if s==[0,0]:
	   D=D+7.5

	if (s[0]-50)**2<=D**2 or (s[0]+50)**2<=D**2\
		or (s[1]-50)**2<=D**2 or (s[1]+50)**2<=D**2:
		return True

	acess=False
	for dx,dy in L:
		if [dx,dy] not in visited and (s[0]-dx)**2+(s[1]-dy)**2<=D**2:
			visited.append([dx,dy])
			if s==[0,0]:
				D=D-7.5
			#每一个都走不通才返回false
			acess=acess or DFS(L,D,[dx,dy],visited)

	return acess

N,D=list(map(int,input().split()))
L=[]
for k in range(N):
	x,y=list(map(int,input().split()))
	L.append([x,y])
	
if DFS(L,D,[0,0]):
	print('Yes')
else:
	print('No')

后面继续有加强版,找到最短路径,按道理使用Dijkstra算法即可,但是这道题目要求当有多条最短路径时输出第一跳距离最小的那条路径,这个纯粹用Dijkstra是实现不了的,暂时还没解决这个测试点。结果如下:
在这里插入图片描述

def Dijkstra(L,N,D,Path):
	dist=[float('inf') for i in range(N+2)]
	dist[0]=0
	visited=[0 for i in range(N+2)]
	while True:
		mind=float('inf')
		position=-1#这里找最小距离直接遍历,不使用小根堆
		for idx in range(N+2):
			if visited[idx]==0 and dist[idx]<=mind:
				mind=dist[idx]
				position=idx
		if position==-1 or position==N+1:
			break
		visited[position]=1

		for idx in range(N+2):
			if visited[idx]==0:
				delta=0
				if L[idx][0]==50:
					delta=min(50-abs(L[position][0]),50-abs(L[position][1]))
				else:
					delta=((L[idx][0]-L[position][0])**2+\
					(L[idx][1]-L[position][1])**2)**0.5
					if position==0:
						delta=delta-7.5
				if delta<=D and delta+dist[position]<dist[idx]:
					dist[idx]=delta+dist[position]
					Path[idx]=position

N,D=input().split()
N=int(N);D=float(D)
if D>=42.5:
	print(1)
else:
	L=[[0,0]]#人的位置也是一个结点
	for k in range(N):
		L.append(list(map(int,input().split())))
	L.append([50])#岸边等效一个节点
	Path=[-1 for i in range(N+2)]	
	Dijkstra(L,N,D,Path)
	if Path[N+1]==-1:
		print(0)
	else:
		l=[]
		idx=Path[N+1]
		while idx>0:
			l.append(idx)
			idx=Path[idx]
		l.reverse()
		print(len(l)+1)
		for idx in l:
			print(' '.join(map(str,L[idx])))
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值