PAT 甲级 1003 Emergency (25分)

题目

1003 Emergency (25分)

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input Specification:

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N ( ≤ 500 ) N (≤500) N(500) - the number of cities (and the cities are numbered from 0 to N − 1 ) N−1) N1), M M M - the number of roads, C 1 a n d C 2 C_1 and C_2 C1andC2 - the cities that you are currently in and that you must save, respectively. The next line contains N N N integers, where the i-th integer is the number of rescue teams in the i i i-th city. Then M lines follow, each describes a road with three integers c 1 , c 2 c_1, c_2 c1,c2​ and L L L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C 1 C_1 C1 to C 2 C_2 C2.

Output Specification:

For each test case, print in one line two numbers: the number of different shortest paths between C 1 a n d C 2 C_1 and C_2 C1andC2, and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input:
5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1
Sample Output:
2 4
题目大意

给出N个城市的救援队数量,M条城市之间的路,求出最短路径条数和一条路径能够得到的最多救援队数量。

思路

Dijkstra算法

代码

#include <bits/stdc++.h>
using namespace std;
const int inf = 1e7;
int main(int argc, const char * argv[]) {
    int N, M, C1, C2, a, b, dis;
    scanf("%d%d%d%d",&N,&M,&C1,&C2);
    vector<int> teams(N), collect(N,0);
    int edge[510][510];
    fill(edge[0], edge[0]+510*510, -1);
    for(int i=0; i<N; i++)
        scanf("%d",&teams[i]);
    for(int i=0; i<M; i++){
        scanf("%d%d%d",&a,&b,&dis);
        edge[a][b] = dis;
        edge[b][a] = dis;
    }
    vector<int> Dist(N, inf);
    vector<int> path(N, 0);
    vector<bool> Visit(N, false);
    Dist[C1] = 0;
    path[C1] = 1;
    collect[C1] = teams[C1];
    for(int i=0; i<N; i++){
        int u = -1;
        int mindis = inf;
        for(int j=0; j<N; j++){
            if(!Visit[j] && Dist[j] < mindis){
                u = j;
                mindis = Dist[j];
            }
        }
        if(u == -1) break;
        Visit[u] = true;
        for(int k=0; k<N; k++){
            if(!Visit[k] && edge[u][k] != -1){
                if(edge[u][k] + Dist[u] < Dist[k]){
                    Dist[k] = edge[u][k] + Dist[u]; // 更新最短距离
                    collect[k] = collect[u] + teams[k]; // 更新救援队数
                    path[k] = path[u]; //更新路径数量
                }else if(edge[u][k] + Dist[u] == Dist[k]){
                    path[k] += path[u];
                    collect[k] = max(collect[k], teams[k] + collect[u]);
                }
            }
        }
    }
    printf("%d %d",path[C2], collect[C2]);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值