1144 The Missing Number (20 point(s))

本文介绍如何使用基本集合方法解决编程问题1144TheMissingNumber,通过排序和查找正整数范围内的缺失数字。关键步骤包括从1开始检查,不找列表最小值,连续数集输出下标加一。展示了C++代码实现和算法解析。
摘要由CSDN通过智能技术生成

1144 The Missing Number (20 point(s))

Given N integers, you are supposed to find the smallest positive integer that is NOT in the given list.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N ( ≤ 1 0 5 ≤10^5 105). Then N integers are given in the next line, separated by spaces. All the numbers are in the range of int.

Output Specification:
Print in a line the smallest positive integer that is missing from the input list.

Sample Input:

10
5 -25 9 6 1 3 4 2 5 17

Sample Output:

7

Experiential Summing-up

Using basic set method, after sorting automatically,then one by one check the positive integer list and figure out the samllist number (from 1 to n ) NOT in the given list.
Significantly, the work should start form 1, not the list’s smallist number.
In other word, if the list begining is not 1, then output 1, not to find the smaller number next the list
One more thing, when the numbers in set(length: n) are continuous, which mean there is no lacking number, the out put n+1. That’s all.


Accepted Code
#include <iostream>
#include <stdio.h>
#include <map>
#include <set>
using namespace std;
int main() {
    int n,x;
    cin>>n;
    set<int>st;
    set<int>::iterator it;
    while(n--)
    {
        cin>>x;
        if(x>0)st.insert(x);
    }
    for(int i=1;i<=st.size()+1;i++)
        if(!st.count(i))
        {
            cout<<i<<endl;
            break;
        }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值