F - Prime Path

F - Prime Path

题目:
The ministers of the cabinet were quite upset by the message from the Chief of Security stating that they would all have to change the four-digit room numbers on their offices.
— It is a matter of security to change such things every now and then, to keep the enemy in the dark.
— But look, I have chosen my number 1033 for good reasons. I am the Prime minister, you know!
— I know, so therefore your new number 8179 is also a prime. You will just have to paste four new digits over the four old ones on your office door.
— No, it’s not that simple. Suppose that I change the first digit to an 8, then the number will read 8033 which is not a prime!
— I see, being the prime minister you cannot stand having a non-prime number on your door even for a few seconds.
— Correct! So I must invent a scheme for going from 1033 to 8179 by a path of prime numbers where only one digit is changed from one prime to the next prime.

Now, the minister of finance, who had been eavesdropping, intervened.
— No unnecessary expenditure, please! I happen to know that the price of a digit is one pound.
— Hmm, in that case I need a computer program to minimize the cost. You don’t know some very cheap software gurus, do you?
— In fact, I do. You see, there is this programming contest going on… Help the prime minister to find the cheapest prime path between any two given four-digit primes! The first digit must be nonzero, of course. Here is a solution in the case above.
1033
1733
3733
3739
3779
8779
8179
The cost of this solution is 6 pounds. Note that the digit 1 which got pasted over in step 2 can not be reused in the last step – a new 1 must be purchased.
Input
One line with a positive number: the number of test cases (at most 100). Then for each test case, one line with two numbers separated by a blank. Both numbers are four-digit primes (without leading zeros).
Output
One line for each case, either with a number stating the minimal cost or containing the word Impossible.
Sample Input
3
1033 8179
1373 8017
1033 1033
Sample Output
6
7
0

代码如下:

//#include<bits/stdc++.h>
#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue> 
using namespace std;

int prime[10010];
int t[5];//用于保存一个四位数的四个位数的值
int vis[10010];//用于判重;
struct Node
{
    int x;//改变一位之后新产生的数字
    int step;//保存步数
};

void find_prime()//打表寻找素数
{
    memset(prime,0,sizeof(prime));
    prime[1] = 1;//1是素数
    for(int i = 2;i < 10010;i++)
    {
        if(prime[i] == 0)
        {
            for(int j = 2;i * j < 10010;j++) prime[i * j] = 1;
        }
    }
}

int bfs(int a,int b)
{
    int temp,num;//分别用于储存中间值和计算后的值
    memset(vis,0,sizeof(vis));//开始时全是新点
    queue<Node> q;
    Node node1,node2;
    node1.step = 0;
    node1.x = a;
    vis[node1.x] = 1;//标记为旧点
    q.push(node1);
    while(!q.empty())
    {
        node1 = q.front();
        q.pop();
        if(node1.x == b) return node1.step;
        t[4] = node1.x % 10;//保存四位数的个位
        t[3] = (node1.x / 10) % 10;//保存十位
        t[2] = (node1.x / 100) % 10;//保存百位
        t[1] = (node1.x / 1000) % 10;//保存千位
        for(int i = 1;i <= 4;i++)
        {
            temp = t[i];//用于保存
            for(int j = 0;j < 10;j++)
            {
                if(t[i] != j)
                {
                    t[i] = j;
                    num = t[1] * 1000 + t[2] * 100 + t[3] * 10 + t[4];
                }
                if(prime[num] == 0 && num >= 1000 && num <= 9999 && vis[num] == 0)
                {
                    node2.step = node1.step + 1;
                    node2.x = num;
                    q.push(node2);
                    vis[num] = 1;
                }
            }
            t[i] = temp;//还原
        }
    }
    return -1;//此时证明没找到满足的点
}

int main()
{
    int T,a,b,ans;
    find_prime();
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&a,&b);
        ans = bfs(a,b);
        if(ans != -1) cout << ans << endl;
        else cout << "Impossible" << endl;
    }
    return 0;
}

打表 + BFS,打表用于找出所有的素数,通过每次改写数字中的某一位来BFS。

转python写法:#!/bin/sh time_stamp=`date +%s` function CheckStop() { if [ $? -ne 0 ]; then echo "execute fail, error on line_no:"$1" exit!!!" exit fi } function GenEcdsaKey() { ec_param_file_path="/tmp/ec_param.pem."$time_stamp openssl ecparam -out $ec_param_file_path -name prime256v1 -genkey CheckStop $LINENO openssl genpkey -paramfile $ec_param_file_path -out $1 CheckStop $LINENO openssl pkey -in $1 -inform PEM -out $2 -outform PEM -pubout CheckStop $LINENO rm $ec_param_file_path echo "gen_ecdsa_key succ prikey_path:"$1" pubkey_path:"$2 } function GenEcdsaSign() { ec_sign_info_file="/tmp/ec_sign_info_file."$time_stamp ec_sign_info_sha256="/tmp/ec_sign_info_sha256."$time_stamp ec_binary_sign_file="/tmp/ec_binary_sign_file."$time_stamp echo -n "$1"_"$2" > $ec_sign_info_file openssl dgst -sha256 -binary -out $ec_sign_info_sha256 $ec_sign_info_file CheckStop $LINENO openssl pkeyutl -sign -in $ec_sign_info_sha256 -out $ec_binary_sign_file -inkey $3 -keyform PEM CheckStop $LINENO openssl base64 -e -in $ec_binary_sign_file -out $4 CheckStop $LINENO rm $ec_sign_info_file $ec_sign_info_sha256 $ec_binary_sign_file echo "gen_ecdsa_sign succ sign_file_path:"$4 } function VerifyEcdsaSign() { ec_sign_info_file="/tmp/ec_sign_info_file."$time_stamp ec_sign_info_sha256="/tmp/ec_sign_info_sha256."$time_stamp ec_binary_sign_file="/tmp/ec_binary_sign_file."$time_stamp echo -n "$1"_"$2" > $ec_sign_info_file openssl dgst -sha256 -binary -out $ec_sign_info_sha256 $ec_sign_info_file CheckStop $LINENO openssl base64 -d -in $4 -out $ec_binary_sign_file CheckStop $LINENO openssl pkeyutl -verify -in $ec_sign_info_sha256 -sigfile $ec_binary_sign_file -pubin -inkey $3 -keyform PEM rm $ec_sign_info_file $ec_sign_info_sha256 $ec_binary_sign_file } function Usage() { echo "Usage:" echo "mmiot_ecdsa_sign.sh gen_ecdsa_key <private_key_file_path> <public_key_file_path>" echo "mmiot_ecdsa_sign.sh gen_ecdsa_sign <product_id> <sn> <private_
05-31
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值