PAT A1007 Maximum Subsequence Sum

Given a sequence of K integers { N​1​​, N​2​​, …, N​K​​ }. A continuous subsequence is defined to be { N​i​​, N​i+1​​, …, N​j​​} where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4
  • 思路: 动态规划:最大连续子序列和问题
  1. 状态转移方程为:dp[i] = max(num[i], dp[i-1] + num[i]); (两个选择)
  2. 边界为:dp[0] = num[0]

同时需要记录以i为子序列尾时,最大子序列的头部元素

  • code:
#include <bits/stdc++.h>
using namespace std;
const int maxn = 100010;
int num[maxn], dp[maxn], dplower[maxn];

int main(){
	int n;
	bool flg = false;
	scanf("%d", &n);
	for(int i = 0; i < n; ++i){
		scanf("%d", &num[i]);
		if(num[i] >= 0) flg = true;	//Wrong 1:包括0 样例5 
	}
	if(flg == false){	//没有一个“非负数” 
		printf("0 %d %d\n", num[0], num[n-1]);		
	}else{
		dp[0] = num[0];
		int last = 0;
		for(int i = 1; i < n; ++i){
			if(num[i] < dp[i-1] + num[i]){	
				dplower[i] = dplower[i-1];
				dp[i] = dp[i-1] + num[i];			
			}else{
				dplower[i] = i;
				dp[i] = num[i];
			}
			if(dp[i] > dp[last]){
//				Max = dp[i];	//Wrong 2: 样例3 最大值要用i=0做初值,因为遍历是从i=1开始的 
				last = i;
			}
		}
		printf("%d %d %d", dp[last], num[dplower[last]], num[last]);
	}
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值