PAT Advanced—1001 A+B Format (20分)

Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).
Input Specification:
Each input file contains one test case. Each case contains a pair of integers a and b where −10​6​​≤a,b≤10​6​​. The numbers are separated by a space.
Output Specification:
For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:
-1000000 9
Sample Output:
-999,991

思路:
  要输出的就是标志格式的整数,从低位开始,每三个要加“,"号。先判断是否是负数,负号单独处理,0单独处理;然后,直接进行对1000取余保存,后面再反序输出这些数,但要注意第一个逗号前面的不一定是三位,后面的都是三位,用printf格式化输出

注意:

  1. 注意题目中的三个用逗号分开,是从低位开始的。就是我们常见的整数格式罢了
  2. 英语能力有待提高,注意抓住关键条件

代码:(C++)

#include<iostream>
#include<vector>

using namespace std;

int main()
{
	int a,b;
	vector<int> v;
	cin>>a>>b;
	a = a+b;
	if(a<0)
	{
		cout<<"-";
		a = -a;
	}
	else if(a==0)
	{
		cout<<"0";
		return 0;
	}
	while(a!=0)
	{
		v.push_back(a%1000);
		a = a/1000;
	}
	for(int i=v.size()-1; i>=0; i--)
	{
		if(i==v.size()-1)
			cout<<v[i];
		else
			printf("%03d",v[i]);
		if(i!=0)
			cout<<",";
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值