题目要求
People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.
Input Specification:
Each input file contains one test case which occupies a line containing the three decimal color values.
Output Specification:
For each test case you should output the Mars RGB value in the following format: first output #, then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a 0 to its left.
Sample Input:
15 43 71
Sample Output:
#123456
翻译
输入10进制的r g b数值,输出13进制的六位数,要求只有一位时加‘0’,字母要大写
代码
#include<iostream>
#include<vector>
using namespace std;
vector<char> v[3];
vector<int> in(3);
int main()
{
cin>>in[0]>>in[1]>>in[2];
cout<<"#";
int cnt=0;
for(int i=0;i<3;i++)
{
do{
cnt++;
char x = in[i] % 13<10 ? in[i]%13 + '0':in[i]%13-10+'A';
v[i].push_back(x);
in[i] = in[i]/13;
}while(in[i]!=0);
if(cnt==1) v[i].push_back('0');
cnt=0;
}
for(int i=0;i<3;i++)
{
for(int j=v[i].size()-1;j>=0;j--)
{
cout<<v[i][j];
}
}
system("pause");
}
思路
一道进制转换的题目。
注意只有一位时前面要加0,其他就不赘述了。