1122 Hamiltonian Cycle

The “Hamilton cycle problem” is to find a simple cycle that contains every vertex in a graph. Such a cycle is called a “Hamiltonian cycle”.

In this problem, you are supposed to tell if a given cycle is a Hamiltonian cycle.

Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive integers N (2<N≤200), the number of vertices, and M, the number of edges in an undirected graph. Then M lines follow, each describes an edge in the format Vertex1 Vertex2, where the vertices are numbered from 1 to N. The next line gives a positive integer K which is the number of queries, followed by K lines of queries, each in the format:

n V1 V2 … Vn
​​
where n is the number of vertices in the list, and V​i’s are the vertices on a path.

Output Specification:

For each query, print in a line YES if the path does form a Hamiltonian cycle, or NO if not.

Sample Input:

6 10
6 2
3 4
1 5
2 5
3 1
4 1
1 6
6 3
1 2
4 5
6
7 5 1 4 3 6 2 5
6 5 1 4 3 6 2
9 6 2 1 6 3 4 5 2 6
4 1 2 5 1
7 6 1 3 4 5 2 6
7 6 1 2 5 4 3 1

Sample Output:

YES
NO
NO
NO
YES
NO

题目大意及思路

哈密顿回路:经过图中的每个顶点,且每个顶点只经过一次。
设置哈希数组,存储路径上每个顶点所经过的次数。只有满足路径经过的顶点数为图中顶点数+1、每个顶点经过次数为1、相邻顶点均可达这三个条件的路径才符合题意。

AC代码

#include <iostream>
#include <vector>
using namespace std;

int main(){
	int N, m, a, b, G[201][201] = {0};
	cin>>N>>m;
	for(int i = 0; i < m; i++){
		cin>>a>>b;
		G[a][b] = 1;
		G[b][a] = 1;
	}
	int k, n, id;
	vector<int> path;
	cin>>k;
	for(int i = 0; i < k; i++){
		int hashTable[201] = {0}; //顶点走过多少次
		path.clear();
		bool flag = true;
		cin>>n;
		for(int j = 0; j < n; j++){
			cin>>id;
			path.push_back(id);
			hashTable[id]++;
		}
		if(n != N + 1 || path[0] != path[n - 1])
			flag = false;
		else{
			for(int j = 1; j < n; j++){
				if(G[path[j - 1]][path[j]] == 0
				|| hashTable[path[j]] != 1 && j != n - 1){
					flag = false;
					break;
				}
				
			}	
		}
		if(flag) cout<<"YES"<<endl;
		else cout<<"NO"<<endl;
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值