PTA甲级 1033 To Fill or Not to Fill (C++)

With highways available, driving a car from Hangzhou to any other city is easy. But since the tank capacity of a car is limited, we have to find gas stations on the way from time to time. Different gas station may give different price. You are asked to carefully design the cheapest route to go.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 positive numbers: C m a x ( ≤ 100 ) C_{max}(≤ 100) Cmax(100), the maximum capacity of the tank; D ( ≤ 30000 ) D (≤30000) D(30000), the distance between Hangzhou and the destination city; D a v g ( ≤ 20 ) D_{avg} (≤20) Davg(20), the average distance per unit gas that the car can run; and N ( ≤ 500 ) N (≤ 500) N(500), the total number of gas stations. Then N N N lines follow, each contains a pair of non-negative numbers: P i P_i Pi, the unit gas price, and D i ( ≤ D ) D_i (≤D) Di(D), the distance between this station and Hangzhou, for i = 1 , ⋯ , N i=1,⋯,N i=1,,N. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the cheapest price in a line, accurate up to 2 decimal places. It is assumed that the tank is empty at the beginning. If it is impossible to reach the destination, print The maximum travel distance = X where X is the maximum possible distance the car can run, accurate up to 2 decimal places.

Sample Input 1:

50 1300 12 8
6.00 1250
7.00 600
7.00 150
7.10 0
7.20 200
7.50 400
7.30 1000
6.85 300

Sample Output 1:

749.17

Sample Input 2:

50 1300 12 2
7.10 0
7.00 600

Sample Output 2:

The maximum travel distance = 1200.00

Caution:

柳神yyds!
下面的代码的核心部分是看了柳神的代码后写出来的

Solution:

// Talk is cheap, show me the code
// Created by Misdirection 2021-09-08 21:24:30
// All rights reserved.

#include <iostream>
#include <vector>
#include <algorithm>

using namespace std;

double cmax, d, davg;
int n;

struct Station{
    double price;
    double dis;

    Station(double p, double d){
        price = p;
        dis = d;
    }
    ~Station(){}
};

bool cmp(Station &a, Station &b){
    if(a.dis != b.dis) return a.dis < b.dis;
    return a.price < b.price;
}

int main(){
    cin >> cmax >> d >> davg >> n;
    // cmax - the maximum capacity of the tank
    // d - the distance between Hangzhou and the destination city
    // davg - the average distance per unit gas that the car can run
    // n - the total number of gas stations

    vector<Station> stations;
    for(int i = 0; i < n; ++i){
        double price;
        double dis;

        cin >> price >> dis;
        stations.emplace_back(price, dis);
    }
    stations.emplace_back(0, d);
    sort(stations.begin(), stations.end(), cmp);

    if(stations[0].dis != 0){
        printf("The maximum travel distance = 0.00\n");
        return 0;
    }

    double totalPrice = 0, nowPrice = stations[0].price, leftDis = 0;
    double nowDis = 0, maxDis = cmax * davg;

    while(nowDis < d){
        int minPricePos = -1;
        double minPrice = 9999999;

        bool hasLower = false;
        
        for(int i = 0; i <= n; ++i){
            if(stations[i].dis <= nowDis) continue;
            if(stations[i].dis > nowDis + maxDis) break;

            if(stations[i].price < nowPrice){
                totalPrice += nowPrice * (stations[i].dis - nowDis - leftDis) / davg;
                nowPrice = stations[i].price;
                leftDis = 0;
                nowDis = stations[i].dis;
                
                hasLower = true;
                break;
            }

            else if(stations[i].price < minPrice){
                minPricePos = i;
                minPrice = stations[i].price;
            }
        }

        if(!hasLower && minPrice != 9999999){
            totalPrice += nowPrice * (maxDis - leftDis) / davg;
            nowPrice = minPrice;
            leftDis = cmax * davg - (stations[minPricePos].dis - nowDis);
            nowDis = stations[minPricePos].dis;
        }
        else if(!hasLower && minPrice == 9999999){
            printf("The maximum travel distance = %.2lf\n", nowDis + maxDis);
            return 0;
        }
    }

    printf("%.2lf\n", totalPrice);
    return 0;
}

在这里插入图片描述

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

负反馈循环

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值