[Loops]D. Liang 4.16 Finding the factors of an integer.c

[Loops]D. Liang 4.16 Finding the factors of an integer

Description

Write a program that reads an integer n and displays all its smallest factors.
For example, if the input ingeger is 120, the output should be as follows:
2
2
2
3
5

Input

An integer n (1<n<20000).

Output

The smallest factors of n in nondescending order, each factor per line.

Sample Input

120

Sample Output

2
2
2
3
5
Thinking analysis: this question is to find all the prime factors of n.

//   Date:2020/3/19
//   Author:xiezhg5
#include <stdio.h>
int main(void)
{
	int i;
	int n;
	scanf("%d",&n);
	int m=n;  //把n的值储存在m中 
    for(i=2;i<=m;i++)  //遍历2到m的所有数字 
    {
    	int k=i;      //用k储存i 
    	while(n%k==0)
    	{
    		printf("%d\n",k); //打印n的因数 
    		n=n/k;       //找因数中的素数 
    	}	
    }
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值