A1124 Raffle for Weibo Followers(20分)PAT 甲级(Advanced Level) Practice(C++)满分题解【map】

John got a full mark on PAT. He was so happy that he decided to hold a raffle(抽奖) for his followers on Weibo -- that is, he would select winners from every N followers who forwarded his post, and give away gifts. Now you are supposed to help him generate the list of winners.

Input Specification:

Each input file contains one test case. For each case, the first line gives three positive integers M (≤ 1000), N and S, being the total number of forwards, the skip number of winners, and the index of the first winner (the indices start from 1). Then M lines follow, each gives the nickname (a nonempty string of no more than 20 characters, with no white space or return) of a follower who has forwarded John's post.

Note: it is possible that someone would forward more than once, but no one can win more than once. Hence if the current candidate of a winner has won before, we must skip him/her and consider the next one.

Output Specification:

For each case, print the list of winners in the same order as in the input, each nickname occupies a line. If there is no winner yet, print Keep going... instead.

Sample Input 1:

9 3 2
Imgonnawin!
PickMe
PickMeMeMeee
LookHere
Imgonnawin!
TryAgainAgain
TryAgainAgain
Imgonnawin!
TryAgainAgain

Sample Output 1:

PickMe
Imgonnawin!
TryAgainAgain

Sample Input 2:

2 3 5
Imgonnawin!
PickMe

Sample Output 2:

Keep going...

题意分析:

用map来存放每个用户是否获奖,注意当一个是因为上一个人已经获奖了而递补到的获奖,那么下一轮获奖就要以当前这个人为基准进行每隔n个人获奖,而不是还是延续初始时的那个轮次

代码如下:

#include<bits/stdc++.h>
using namespace std;
int main()
{
	//m是所有转发数,n是获胜者间隔人数,s是第一个获胜者的序号
	int m, n, s;
	map<string, int> waitlist;
	vector<string> res;
	cin >> m >> n >> s;
	for (int i = 1; i <= m; i++)
	{
		string name;
		cin >> name;
		if (waitlist[name] == 1)s++;
		if (i==s&&waitlist[name] == 0) {
			waitlist[name]++;
			res.push_back(name);
			s = s + n;
		}
	}
	if (res.size() == 0)cout << "Keep going..." << endl;
	else {
		for (int i = 0; i < res.size(); i++)
			cout << res[i] << endl;
	}
	return 0;
}

运行结果如下: 

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值