POJ-3186 Treats for the Cows (区间DP)

1 篇文章 0 订阅

Description

FJ has purchased N (1 <= N <= 2000) yummy treats for the cows who get money for giving vast amounts of milk. FJ sells one treat per day and wants to maximize the money he receives over a given period time.

The treats are interesting for many reasons:

The treats are numbered 1..N and stored sequentially in single file
in a long box that is open at both ends. On any day, FJ can retrieve
one treat from either end of his stash of treats.
Like fine wines and delicious cheeses, the treats improve with age and command greater prices.
The treats are not uniform: some are better and have higher intrinsic value. Treat i has value v(i) (1 <= v(i) <= 1000).
Cows pay more for treats that have aged longer: a cow will pay v(i)*a for a treat of age a.

Given the values v(i) of each of the treats lined up in order of the
index i in their box, what is the greatest value FJ can receive for
them if he orders their sale optimally?

The first treat is sold on day 1 and has age a=1. Each subsequent day
increases the age by 1.

Input

Line 1: A single integer, N

Lines 2..N+1: Line i+1 contains the value of treat v(i)

Output

Line 1: The maximum revenue FJ can achieve by selling the treats

Sample Input

5
1
3
1
5
2

Sample Output

43


思路:

  • 典型的区间DP,dp(i, j)表示从左取i个,从右取j个的最大值,即取区间(1~i)U(j~n)的最大值。
  • 状态转移方程为dp(i, j) = max(dp(i-1, j)+(i+j)*a[i], dp(i, j-1)+(i+j)*a[n-j+1])。
  • 最大值就是max(dp(0, n), dp(1, n-1), ……, dp(n-1, 1), dp(n, 0))。
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cmath>
#include<cstring>
#include<set>
#include<map>
#include<queue>

using namespace std;
int dp[2010][2010], a[2010];

int main() {
    std::ios::sync_with_stdio(false);
    int n;
    while(cin>>n) {
        memset(dp, 0, sizeof(dp));
        memset(a, 0, sizeof(a));
        for (int i = 1; i <= n; ++i) cin>>a[i];
        for (int i = 1; i <= n; ++i){
            dp[i][0] = dp[i-1][0] + a[i]*i;
            dp[0][i] = dp[0][i-1] + a[n-i+1]*i;
        }
        for (int i = 1; i <= n; ++i)
            for (int j = 1; j <= n; ++j){
                if (i+j > n) break;
                dp[i][j] = max(dp[i-1][j]+(i+j)*a[i], dp[i][j-1]+(i+j)*a[n-j+1]);
            }
        int ans = dp[0][n];
        for (int i = 1; i <= n; ++i)
            ans = max(dp[i][n-i], ans);
        cout<<ans<<endl;
    }
    return 0;
}

看了别人的写法发现自己这种写法不够好,而且没有完全掌握好区间DP。用dp(i, j)表示[i, j]的最大值,从子问题推出最终解显然是更好的写法

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cmath>
#include<cstring>
#include<set>
#include<map>
#include<queue>

using namespace std;

int dp[2010][2010], a[2010];  
int main() {
    std::ios::sync_with_stdio(false);  
    int n;
    cin>>n;  
    for(int i = 1; i <= n; ++i)  
        cin>>a[i];
    for(int i = n; i >= 1; --i)  
        for(int j = i; j <= n; ++j)  
            dp[i][j] = max(dp[i+1][j]+a[i]*(n+i-j), dp[i][j-1]+a[j]*(n+i-j));  
    cout<<dp[1][n]<<endl;
    return 0;  
}  
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值