UVA 10115 子符串替换

yiyi:

第一遍提交WA,看了好久才发现,假如你第一个规则已经用完了,跳到了第二个规则后,就不能返回再用第一个规则了。

题目中就有说要注意,我居然忽视了这句,真的是作死。(知道了strstr()这个函数,真实神奇!!!!)。

题目大意:给出n对可替换字符串,对给出的一个字符串,对其进行替换,输出无法替换后的字符串(同一对可能替换不只一次,按给出替换对的顺序进行修改)

Text-processing tools like awk and sed allow you to automatically perform a sequence of editing operations based on a script. For this problem we consider the specific case in which we want to perform a series of string replacements, within a single line of text, based on a fixed set of rules. Each rule specifies the string to find, and the string to replace it with, as shown below.

RuleFindReplace-by
1.banbab
2.bababe
3.anaany
4.ba bhind the g

To perform the edits for a given line of text, start with the first rule. Replace the first occurrence of the find string within the text by the replace-by string, then try to perform the same replacement again on the new text. Continue until the find string no longer occurs within the text, and then move on to the next rule. Continue until all the rules have been considered. Note that (1) when searching for a find string, you always start searching at the beginning of the text, (2) once you have finished using a rule (because the find string no longer occurs) you never use that rule again, and (3) case is significant.

For example, suppose we start with the line

banana boat

and apply these rules. The sequence of transformations is shown below, where occurrences of a find string are underlined and replacements are boldfaced. Note that rule 1 was used twice, then rule 2 was used once, then rule 3 was used zero times, and then rule 4 was used once.

 BeforeAfter
banana boatbabana boat
babana boatbababa boat
bababa boatbeba boat
beba boatbehind the goat

The input contains one or more test cases, followed by a line containing only 0 (zero) that signals the end of the file. Each test case begins with a line containing the number of rules, which will be between 1 and 10. Each rule is specified by a pair of lines, where the first line is the find string and the second line is the replace-by string. Following all the rules is a line containing the text to edit. For each test case, output a line containing the final edited text.

Both find and replace-by strings will be at most 80 characters long. Find strings will contain at least one character, but replace-bystrings may be empty (indicated in the input file by an empty line). During the edit process the text may grow as large as 255 characters, but the final output text will be less than 80 characters long.

The first test case in the sample input below corresponds to the example shown above.

Example input:

4
ban
bab
baba
be
ana
any
ba b
hind the g
banana boat
1
t
sh
toe or top
0

Example output:

behind the goat
shoe or shop
daan 
#include<stdio.h>
#include<string.h>
#include<string>
#include <iostream>
using namespace std;


int main () {
		int n, i, f = 0;
		char sch[15][85], rep[15][85],tem[260];
		char ch[260];
		int t, k;
		char *move = NULL;
		while (scanf("%d", &n) != EOF) {
			getchar();
			memset(sch, 0, sizeof(sch));
			memset(rep, 0, sizeof(rep));
			memset(ch, 0, sizeof(ch));
			if (n == 0)
				break;
			for (i = 0; i < n; i++) {
				gets(sch[i]);
				gets(rep[i]);
			}
			gets(ch);
			//getchar();
			for (int j = 0; j < n; j++) {
				  
				t = strlen(sch[j]);
				k = strlen(rep[j]);
				do{
					  
                move = strstr(ch, sch[j]);
                if (move == NULL)  
                    continue;  
                strcpy(tem, move + t);    
                strcpy(move, rep[j]);  
                strcpy(move + k, tem); 
				move = strstr(ch, sch[j]); 
					//j = -1;
				}
				while (move != NULL);
			}
			puts(ch);
		//printf("%s\n", ch);
		}
		//system("pause");
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值