UAV12096 The SetStack Computer

Problem:

Background from Wikipedia: “Set theory is a branch of mathematics created principally by the German mathematician Georg Cantor at the end of the 19th century. Initially controversial, set theory has come to play the role of a foundational theory in modern mathematics, in the sense of a theory invoked to justify assumptions made in mathematics concerning the existence of mathematical objects (such as numbers or functions) and their properties.Formal versions of set theory also have a foundational role to play as specifying a theoretical ideal of mathematical rigor in proofs.”

Given this importance of sets, being the basis of mathematics, a set of eccentric theorist set off to construct a supercomputer operating on sets instead of numbers. The initial SetStack Alpha is under construction, and they need you to simulate it in order to verify the operation of the prototype.

The computer operates on a single stack of sets, which is initially empty. After each operation, the cardinality of the topmost set on the stack is output. The cardinality of a set S is denoted |S| and is the number of elements in S. The instruction set of the SetStack Alpha is PUSH, DUP, UNION, INTERSECT, and ADD.

• PUSH will push the empty set {} on the stack.
• DUP will duplicate the topmost set (pop the stack, and then push that set on the stack twice).
• UNION will pop the stack twice and then push the union of the two sets on the stack.
• INTERSECT will pop the stack twice and then push the intersection of the two sets on the stack.
• ADD will pop the stack twice, add the first set to the second one, and then push the resulting set on the stack.

For illustration purposes, assume that the topmost element of the stack is
A = {{}, {{}}}
and that the next one is
B = {{}, {{{}}}}
For these sets, we have |A| = 2 and |B| = 2. Then:
• UNION would result in the set {{}, {{}}, {{{}}}}. The output is 3.
• INTERSECT would result in the set {{}}. The output is 1.
• ADD would result in the set {{}, {{{}}}, {{},{{}}}}. The output is 3.

Input
An integer 0 ≤ T ≤ 5 on the first line gives the cardinality of the set of test cases. The first line of each test case contains the number of operations 0 ≤ N ≤ 2000. Then follow N lines each containing one of the five commands. It is guaranteed that the SetStack computer can execute all the commands in the sequence without ever popping an empty stack.
Output
For each operation specified in the input, there will be one line of output consisting of a single integer. This integer is the cardinality of the topmost element of the stack after the corresponding command has executed. After each test case there will be a line with ‘***’ (three asterisks).

Sample Input
2
9
PUSH
DUP
ADD
PUSH
ADD
DUP
ADD
DUP
UNION
5
PUSH
PUSH
ADD
PUSH
INTERSECT
Sample Output
0
0
1
0
1
1
2
2
2
**
0
0
1
0
0
**

根据紫书的方法,自己写的AC代码:

#include<iostream>
#include<set>
#include<vector>
#include<map>
#include<stack>
#include<string>
#include<algorithm>
using namespace std;

vector<set<int> > assign_ID;
map<set<int>,int> mapping_set;
stack<int> ss;

int GetID(const set<int> &iset){
	if(!mapping_set.count(iset)){
		assign_ID.push_back(iset);
		mapping_set[iset] = assign_ID.size() - 1;
	}
	return mapping_set[iset];
}

int main(void){
	int t;
	cin >> t;
	while(t--){
		int n,i;
		cin >> n;
		for(i=0; i<n; i++){
			string command;
			cin >> command;
			int top_num;
			if(command[0] == 'P'){
				set<int> iset;
				int num_id;
				num_id = GetID(iset);
				ss.push(num_id);
			}
			else if(command[0] == 'D'){
				ss.push(ss.top());
			}
			else{
				int a,b,num_id;
				set<int> iset;
				a = ss.top();ss.pop();
				b = ss.top();ss.pop();
				if(command[0] == 'U'){
					set_union(assign_ID[a].begin(),assign_ID[a].end(),assign_ID[b].begin(),assign_ID[b].end(),inserter(iset,iset.begin()));
					num_id = GetID(iset);
					ss.push(num_id);
				}
				else if(command[0] == 'I'){
					set_intersection(assign_ID[a].begin(),assign_ID[a].end(),assign_ID[b].begin(),assign_ID[b].end(),inserter(iset,iset.begin()));
					num_id = GetID(iset);
					ss.push(num_id);
				}
				else if(command[0] == 'A'){
					iset = assign_ID[b];
					iset.insert(a);
					num_id = GetID(iset);
					ss.push(num_id);
				}
			}
			top_num = ss.top();
			cout << assign_ID[top_num].size() << endl;
		}
		cout << "***\n";
	}
	return 0;
}

首先有几个小点:

1.set_intersection和set_union这些函数的头文件不是set,是algorithm
2.

vector<set<int> > assign_ID;

这个> > 一定中间空一格,不然会被识别为流输入符

然后是紫书上面说的方法:

(我是不看不会,看了才会呜呜)
这道题蛮抽象的,是一个模拟题,模拟栈很容易想到用stack,但是我的知识盲区是怎么表示这些集合,怎么具体化表示这些集合的不同以及里面的一些元素。刘汝佳的思路就是给每个不同的集合编一个独特的号码,而且集合内部的元素也是int号码。那么这个问题就解决了,建立一个set来表示集合。

因为要给这些集合编号吗,所以用到一个vector和map,map<set,int>就是集合以及其对应的号码,而为了保证每个集合的号码都是不一样的,所以就要用到vector,每次有新的没出现过的set就把它压入vector,用此时vector.size()-1作为这个集合的号码,这样也可以直接通过号码找到集合。

其中GetID这个函数就是来实现这个功能的。

总之这个技巧很巧,可能学到了吧……(学废了……)

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值