变相的欧拉方程

C - GCD
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

The greatest common divisor GCD(a,b) of two positive integers a and b,sometimes written (a,b),is the largest divisor common to a and b,For example,(1,2)=1,(12,18)=6. 
(a,b) can be easily found by the Euclidean algorithm. Now Carp is considering a little more difficult problem: 
 Given integers N and M, how many integer X satisfies 1<=X<=N and (X,N)>=M.

Input

The first line of input is an integer T(T<=100) representing the number of test cases. The following T lines each contains two numbers N and M (2<=N<=1000000000, 1<=M<=N), representing a test case.

Output

For each test case,output the answer on a single line.

Sample Input

3
1 1
10 2
10000 72

Sample Output

1
6

260

思路:

本题要求的是比x小的数中与x的最大公约数比y大的数的个数

假设与y相等

即gcd(x,m)=y;

稍微转化一下就是gcd(x/y,m/y)=1;

转化为比x/y小的数中与x/y互质的数的个数

套用欧拉方程的模板即可

ac:代码

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int phi(int n)
{
    int rea=n;
    for(int i=2;i*i<=n;i++)
    {
        if(n%i==0)
        {
            rea=rea-rea/i;
            while(n%i==0)
            n/=i;
        }
    }
    if(n>1)
    rea=rea-rea/n;
    return rea;
}
int main()
{
    int n,x,y;
    cin>>n;
    while(n--)
    {
        scanf("%d%d",&x,&y);
        int ans=0;
        for(int i=1;i*i<=x;i++)
        {
            if(x%i==0)
            {
                if(i<y&&(x/i)>=y)
                ans+=phi(i);
                if(i>=y)
                {
                    ans+=phi(i);
                    if((x/i)>=y&&(x/i)!=i)
                    ans+=phi(x/i);
                }
            }
        }
        cout<<ans<<endl;
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值