【PAT】1073. Scientific Notation (20)【字符串处理】

题目描述

Scientific notation is the way that scientists easily handle very large numbers or very small numbers. The notation matches the regular expression [+-][1-9]”.”[0-9]+E[+-][0-9]+ which means that the integer portion has exactly one digit, there is at least one digit in the fractional portion, and the number and its exponent’s signs are always provided even when they are positive.

Now given a real number A in scientific notation, you are supposed to print A in the conventional notation while keeping all the significant figures.

翻译:科学计数法是一种让科学家可以很轻松的处理非常大的数字或非常小的数字的方法。其符号用正则表达式表示为[+-][1-9]”.”[0-9]+E[+-][0-9]+,即整数部分有且只有一位数字,小数部分至少有一位数字,并且它的数字和指数符号总是会提供即使它们为正数。
现在给你一个用科学计数法表示的实数A,你需要按照传统格式输出A并保留所有的有效数字。

IPNUT FORMAT

Each input file contains one test case. For each case, there is one line containing the real number A in scientific notation. The number is no more than 9999 bytes in length and the exponent’s absolute value is no more than 9999.

翻译:每个输入文件包含一组测试数据。对于每组输入数据,第一行包括一个用科学计数法表示的实数A。数字位数的长度不超过9999,并且指数的绝对值不超过9999。

OUTNUT FORMAT

For each test case, print in one line the input number A in the conventional notation, with all the significant figures kept, including trailing zeros,

翻译:对于每组测试数据,输出一行传统格式下的数字A,并保留所有的有效数字,包括尾部0。


Sample Input 1:

+1.23400E-03

Sample Output 1:

0.00123400


Sample Input 2:

1.2E+10

Sample Output 2:

12000000000


解题思路

这道题主要是字符串的处理,如果指数为负则添加前导0,为正数时判断输出位数是否达到指数,如果未达到在末尾输出0。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<string>
#include<algorithm>
#define INF 99999999
using namespace std;
char s[10010];
int main(){
    scanf("%s",s);
    int length=strlen(s);
    int flag=0,wei=0,symbol=0;
    for(int i=0;i<length;i++){
        if(i==0&&s[i]!='+')printf("-");
        if(flag&&s[i]=='-')symbol=1;
        if(flag&&s[i]>='0'&&s[i]<='9')wei=wei*10+s[i]-'0';
        if(s[i]=='E')flag=i;
    }
    if(symbol==1){
        printf("0.");
        for(int i=1;i<wei;i++)printf("0");
        for(int i=1;i<flag;i++){
            if(s[i]!='.')printf("%c",s[i]);
        }
    }
    else {
        int f=0;
        for(int i=1;i<flag;i++){
            if(i>wei+2&&!f)printf("."),f=1;
            if(s[i]!='.')printf("%c",s[i]);
        }
        if(wei)
        for(int i=0;i<wei-flag+3;i++){
            printf("0");
        }
    }
    printf("\n");
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值