【PAT】1126. Eulerian Path (25)【连通图判断】

题目描述

In graph theory, an Eulerian path is a path in a graph which visits every edge exactly once. Similarly, an Eulerian circuit is an Eulerian path which starts and ends on the same vertex. They were first discussed by Leonhard Euler while solving the famous Seven Bridges of Konigsberg problem in 1736. It has been proven that connected graphs with all vertices of even degree have an Eulerian circuit, and such graphs are called Eulerian. If there are exactly two vertices of odd degree, all Eulerian paths start at one of them and end at the other. A graph that has an Eulerian path but not an Eulerian circuit is called semi-Eulerian.

Given an undirected graph, you are supposed to tell if it is Eulerian, semi-Eulerian, or non-Eulerian.

翻译:在图论中,欧拉路径是图中每条边只经过一次的路径。类似地,欧拉回路是由相同顶点开始和结束的欧拉路径。在1736年莱昂哈德·欧拉解决著名的哥尼斯堡七桥问题时,首先讨论了这些问题。摘要证明了具有偶次顶点的连通图具有欧拉电路,这种图称为欧拉图。如果恰好有两个奇数次的顶点,所有的欧拉路径都从其中一个顶点开始,在另一个顶点结束。有欧拉路径但没有欧拉回路的图称为半欧拉图。
给定一个无向图,你应该知道它是欧拉回路,半欧拉回路,还是非欧拉回路。

Input Specification:

Each input file contains one test case. Each case starts with a line containing 2 numbers N (≤ 500), and M, which are the total number of vertices, and the number of edges, respectively. Then M lines follow, each describes an edge by giving the two ends of the edge (the vertices are numbered from 1 to N).

翻译:每个输入文件包含一组测试数据。每组测试数据第一行包括2个数字N (≤ 500), 和M,分别表示节点的总个数和边的条数。接下来M行,每行给出边的两个顶点来描述一条边。(顶点被编号为1到N)。

Output Specification:

For each test case, first print in a line the degrees of the vertices in ascending order of their indices. Then in the next line print your conclusion about the graph – either Eulerian, Semi-Eulerian, or Non-Eulerian. Note that all the numbers in the first line must be separated by exactly 1 space, and there must be no extra space at the beginning or the end of the line.

翻译:对于每组测试数据,第一行按索引升序输出顶点的度数。然后在下一行输出关于图的结论——是欧拉回路,半欧拉回路,或非欧拉回路。注意第一行中的所有数字之间必须用空格隔开,行首或行尾处无多余空格。


Sample Input 1:

7 12
5 7
1 2
1 3
2 3
2 4
3 4
5 2
7 6
6 3
4 5
6 4
5 6


Sample Output 1:

2 4 4 4 4 4 2
Eulerian


Sample Input 2:

6 10
1 2
1 3
2 3
2 4
3 4
5 2
6 3
4 5
6 4
5 6


Sample Output 2:

2 4 4 4 3 3
Semi-Eulerian


Sample Input 3:

5 8
1 2
2 5
5 4
4 1
1 3
3 2
3 4
5 3


Sample Output 3:

3 3 4 3 3
Non-Eulerian


解题思路

计算每一个点的度数,实际上就是计算输入时顶点的次数,然后判断是否为联通图。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<string>
#include<queue>
#include<algorithm>
#define INF 99999999
using namespace std;
int N,M;
queue<int> q;
vector<int> vec[510];
int v[510];
int lcount=0;
void fun(){
	q.push(1);
	while(!q.empty()&&lcount!=N){
		int temp=q.front();q.pop();
		if(v[temp])continue;
		else v[temp]=1,lcount++;
		for(int i=0;i<vec[temp].size();i++){
			q.push(vec[temp][i]);
		}
	}
}
int main(){
	scanf("%d%d",&N,&M);
	int a,b;
	for(int i=0;i<M;i++){
		scanf("%d%d",&a,&b);
		vec[a].push_back(b);
		vec[b].push_back(a);
	}
	int ccount=0;
	for(int i=1;i<=N;i++){
		if(i<N)	printf("%d ",vec[i].size());
		else 	printf("%d\n",vec[i].size());
		if(vec[i].size()%2!=0)ccount++;
	}
	fun();
	if(lcount==N&&ccount==0)printf("Eulerian\n");
	else if(lcount==N&&ccount==2)printf("Semi-Eulerian\n");
	else printf("Non-Eulerian\n");
	exit(0);
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值