poj 3267 The Cow Lexicon

题目链接:点击打开链

Description

Few know that the cows have their own dictionary with W (1 ≤ W ≤ 600) words, each containing no more 25 of the characters 'a'..'z'. Their cowmunication system, based on mooing, is not very accurate; sometimes they hear words that do not make any sense. For instance, Bessie once received a message that said "browndcodw". As it turns out, the intended message was "browncow" and the two letter "d"s were noise from other parts of the barnyard.

The cows want you to help them decipher a received message (also containing only characters in the range 'a'..'z') of length L (2 ≤ L ≤ 300) characters that is a bit garbled. In particular, they know that the message has some extra letters, and they want you to determine the smallest number of letters that must be removed to make the message a sequence of words from the dictionary.

Input

Line 1: Two space-separated integers, respectively:  W and  L 
Line 2:  L characters (followed by a newline, of course): the received message 
Lines 3.. W+2: The cows' dictionary, one word per line

Output

Line 1: a single integer that is the smallest number of characters that need to be removed to make the message a sequence of dictionary words.

Sample Input

6 10
browndcodw
cow
milk
white
black
brown
farmer

Sample Output

2
题目大意:给出一个长为L的字符串,再给处w个字符串,问最少需要去掉几个字母,能由这w个其中的字符串表示
基本思路:简单dp;从字符串s的最后一个字母开始往前dp,dp[i]=min(dp[i],ss-i-len[j]+dp[ss]);
每一个带刺都遍历一次,看删去几个字母后可以与之匹配,在更新dp
 
#include <iostream>
#include<cstring>
#include<cstdio>
#include<cmath>

using namespace std;

int main()
{
    int w,l;
    int dp[1000];
    char s[1000];
    char str[1000][100];
    int len[1000];
    while(cin>>w>>l)
    {
        cin>>s;
        for(int i=0;i<w;i++)
        {
            cin>>str[i];
            len[i]=strlen(str[i]);
        }
        memset(dp,0,sizeof(dp));
        for(int i=l-1;i>=0;i--)
        {
            dp[i]=dp[i+1]+1;
            for(int j=0;j<w;j++)
            {
                if(str[j][0]==s[i]&&i+len[j]<=l)
                {
                    int t=0;
                    int ss=i;
                    while(ss<l)
                    {
                        if(str[j][t]==s[ss++])
                        {
                            t++;
                        }
                        if(t==len[j])
                        {
                            dp[i]=min(dp[i],ss-i-len[j]+dp[ss]);
                        }
                    }
                }
            }
        }
        cout<<dp[0]<<endl;
    }
    return 0;
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值