令人崩溃的Libalf

在技术发展如此迅猛的今天,为什么老师要让我用一个最后更新时间在2011年的库,着实是让我非常的难过了。提到过这个自动机学习框架的文献少之又少,然后我继续我的一脸懵逼学习历程。

官网链接:http://libalf.informatik.rwth-aachen.de/index.php?page=home

老旧的网页,朴素的气息,三个版本0.1,0.2,0.3。没错,连一个1都没有,一度让我怀疑这玩意儿到底能不能用。


这个documentation已经n年过去了-。-还在soon!本来想跟着它的java demo学习一下,然后发现它的第一个版本并不能在windows上使用,不能编译成.dll。真是令人窒息的操作,而且这里我也不准备用java进行编程,主要是用c++,如果用java的话,推荐另外一个库:https://learnlib.de/【看看别人的,最新版本2018年】

我想试试能不能用vs直接编译它的example,然后就发生了


内心很复杂,然后还是决定用网站上写的方法,用MinGw来进行编译QAQ先下载安装【省略】然后我用msys打开,然后在libalf/src make,再打开examples的文件夹,输入

这是我的库的安装位置,请根据自己的安装位置进行调整

生成一个exe文件


运行


ok~调试成功

阅读更多
个人分类: Model Learning
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页

关闭
关闭
关闭