hdu1711 Number Sequence

Number Sequence

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 12546    Accepted Submission(s): 5716


Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
 

Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
 

Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
 

Sample Input
  
  
2 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 1 3 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 2 1
 

Sample Output
  
  
6 -1
 

Source
HDU 2007-Spring Programming Contest 
/*
注意新修订的c++11里边next是关键字,不能用next,其余就是数字KMP,找到配对的第一个的初始位置就行。加油!!!
Time:2015-3-19 17:26
*/
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
const int MAXN=10000+10;
const int MAXM=1000000+10;
int str[MAXN],pattern[MAXM];
int n,m;
int nxt[MAXN];
void Get_nxt(){
    int i,j;
    i=0;j=-1;
    nxt[0]=-1;
    while(i<m){
        if(j==-1||str[i]==str[j]){
            i++;
            j++;
            nxt[i]=j;
        }else
            j=nxt[j];
    }
}
int KMP(){
    Get_nxt();
    int i,j;
    i=0,j=0;
    int k=-1;
    while(i<n){
        if(j==-1||str[j]==pattern[i]){
            i++; j++;
        }else
            j=nxt[j];

        if(j==m){
            k=i-m+1;
            return k;
        }
    }
    return -1;
}
int main(){
    int T;
    scanf("%d",&T);
    while(T--){
       scanf("%d%d",&n,&m);
       for(int i=0;i<n;i++){
        scanf("%d",&pattern[i]);
       }
       for(int i=0;i<m;i++){
        scanf("%d",&str[i]);
       }
       printf("%d\n",KMP());
    }
return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值