hdu 1503:Advanced Fruits(动态规划+路径输出)

I - Advanced Fruits
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

The company "21st Century Fruits" has specialized in creating new sorts of fruits by transferring genes from one fruit into the genome of another one. Most times this method doesn't work, but sometimes, in very rare cases, a new fruit emerges that tastes like a mixture between both of them. 

A big topic of discussion inside the company is "How should the new creations be called?" A mixture between an apple and a pear could be called an apple-pear, of course, but this doesn't sound very interesting. The boss finally decides to use the shortest string that contains both names of the original fruits as sub-strings as the new name. For instance, "applear" contains "apple" and "pear" (APPLEar and apPlEAR), and there is no shorter string that has the same property. 
A combination of a cranberry and a boysenberry would therefore be called a "boysecranberry" or a "craboysenberry", for example. 

Your job is to write a program that computes such a shortest name for a combination of two given fruits. Your algorithm should be efficient, otherwise it is unlikely that it will execute in the alloted time for long fruit names. 

Input

Each line of the input contains two strings that represent the names of the fruits that should be combined. All names have a maximum length of 100 and only consist of alphabetic characters. 
Input is terminated by end of file.

Output

For each test case, output the shortest name of the resulting fruit on one line. If more than one shortest name is possible, any one is acceptable.

Sample Input

apple peach
ananas banana
pear peach

Sample Output

appleach
bananas
pearch

求最长公共子序列,然后合并。看懂题意应该就有思路了

在此两段代码,先粘别人的吧,写的比我好

#include<cstdio>
#include<cstring>
using namespace std;
char a[105],b[105];
int pre[105][105];
void out(int i,int j)
{
    if(!i&&!j)return;
    if(pre[i][j]==j+1)
    {
        out(i-1,j-1);
        putchar(a[i]);
    }
    else if(pre[i][j]==j)
    {
        out(i-1,j);
        putchar(a[i]);
    }
    else
    {
        out(i,j-1);
        putchar(b[j]);
    }
}
void LCS()
{
    int n=strlen(a+1),m=strlen(b+1),i,j,dp[105][105]= {0};
    for(i=1; i<=n; i++)
        for(j=1; j<=m; j++)
            if(a[i]==b[j])
            {
                dp[i][j]=dp[i-1][j-1]+1;
                pre[i][j]=j+1;
            }
            else if(dp[i][j-1]>dp[i-1][j])
            {
                dp[i][j]=dp[i][j-1];
                pre[i][j]=j-1;
            }
            else
            {
                dp[i][j]=dp[i-1][j];
                pre[i][j]=j;
            }
    out(n,m);
    puts("");
}
int  main()
{
    while(scanf("%s %s",a+1,b+1)==2)
        LCS();
}

自己的:

#include<iostream>
#include<cstring>
#include<cmath>
#include<string>
#include<cstdio>
using namespace std;
const int MAXN=105;
char s1[MAXN],s2[MAXN];
int f[MAXN][MAXN];
int key[MAXN][MAXN];
char ans[MAXN];
int en,snd,t1,t2;
struct node
{
    char c;int pre;
}path[MAXN*5];
int MAX(const int a,const int b){return a>b?a:b;}

void dp()
{
    int i,j;
    en=0;
    memset(f,0,sizeof f);
    memset(key,-1,sizeof key);
    for(i=1;i<=t1;i++)
        for(j=1;j<=t2;j++)
        {
            if(s1[i-1]==s2[j-1])
            {
                f[i][j]=f[i-1][j-1]+1;
                path[en].c=s1[i-1];
                path[en].pre=key[i-1][j-1];
                key[i][j]=en++;
            }
            else
            {
                if(f[i-1][j]>f[i][j-1])
                {
                    f[i][j]=f[i-1][j];
                    key[i][j]=key[i-1][j];
                }
                else
                {
                    f[i][j]=f[i][j-1];
                    key[i][j]=key[i][j-1];
                }
            }
        }
}
void showpath(int id)
{
    if(id==-1)return ;
    showpath(path[id].pre);
    ans[snd++]=path[id].c;
}
int main()
{
    int i,j,k;
    //freopen("123.txt","r",stdin);
    while(~scanf("%s%s",&s1,&s2))
    {
        t1=strlen(s1);
        t2=strlen(s2);
        dp();
        snd=0;
        showpath(key[t1][t2]);
		ans[snd]='\0';
		int cur1=0,cur2=0,cur3=0;
        while(1)
		{
			if(s1[cur1]==ans[cur3]&&s2[cur2]!=ans[cur3])
			{
				printf("%c",s2[cur2++]);
			}
			else if(s2[cur2]==ans[cur3]&&s1[cur1]!=ans[cur3])
			{
				printf("%c",s1[cur1++]);
			}
			else if(s1[cur1]==s2[cur2]&&s2[cur2]==ans[cur3])
			{
				printf("%c",s2[cur2++]);
				cur1++;cur3++;
			}
			else 
			{
				printf("%c%c",s1[cur1++],s2[cur2++]);
			}
			if(cur3==snd)
			{
				printf("%s%s",s1+cur1,s2+cur2);
				break;
			}
		}
		printf("\n");
    }
    return 0;
}

哎,对问题没分析透彻,写麻烦了

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值