hdu Reward(拓扑排序)

N - Reward
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Dandelion's uncle is a boss of a factory. As the spring festival is coming , he wants to distribute rewards to his workers. Now he has a trouble about how to distribute the rewards.
The workers will compare their rewards ,and some one may have demands of the distributing of rewards ,just like a's reward should more than b's.Dandelion's unclue wants to fulfill all the demands, of course ,he wants to use the least money.Every work's reward will be at least 888 , because it's a lucky number.
 

Input

One line with two integers n and m ,stands for the number of works and the number of demands .(n<=10000,m<=20000)
then m lines ,each line contains two integers a and b ,stands for a's reward should be more than b's.
 

Output

For every case ,print the least money dandelion 's uncle needs to distribute .If it's impossible to fulfill all the works' demands ,print -1.
 

Sample Input

       
       
2 1 1 2 2 2 1 2 2 1
 

Sample Output

       
       
1777 -1
 
题意:发工资,满足所有a>b,求工资总量最小
分析:拓补排序
#include<iostream>
#include<cstring>
#include<vector>
#include<cstdio>
#include<queue>
#include<cmath>
using namespace std;
const int MAXN=10000+6;
vector<int>vec[MAXN];
int sum[MAXN],in[MAXN];
int n,m;

void init()
{
	int i;
	for(i=1;i<=n;i++)
	{
		sum[i]=in[i]=0;
		vec[i].clear();
	}
}
void add_ded(int a,int b)
{
	vec[a].push_back(b);
	in[b]++;
}
bool topsort()
{
	int cnt,i;
	queue<int>q;
	for(i=1;i<=n;i++)
		if(!in[i])q.push(i);
	cnt=0;
	while(!q.empty())
	{
		int x=q.front();q.pop();
		cnt++;
		for(i=0;i<vec[x].size();i++)
		{
			if(sum[x]+1>sum[vec[x][i]])sum[vec[x][i]]=sum[x]+1;
			if(--in[vec[x][i]]==0)q.push(vec[x][i]);
		}
	}
	return cnt==n;
}
int main()
{
	int i,a,b;
	while(~scanf("%d%d",&n,&m))
	{
		init();
		for(i=0;i<m;i++)
		{
			scanf("%d%d",&a,&b);
			add_ded(b,a);
		}
		if(topsort())
		{
			int ans=0;
			for(i=1;i<=n;i++)
				ans+=sum[i];
			printf("%d\n",n*888+ans);
		}
		else printf("-1\n");
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值