PAT-甲级-1127 ZigZagging on a Tree (30 分)

60 篇文章 0 订阅

1127 ZigZagging on a Tree (30 分)

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences. And it is a simple standard routine to print the numbers in level-order. However, if you think the problem is too simple, then you are too naive. This time you are supposed to print the numbers in "zigzagging order" -- that is, starting from the root, print the numbers level-by-level, alternating between left to right and right to left. For example, for the following tree you must output: 1 11 5 8 17 12 20 15.

zigzag.jpg

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the inorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the zigzagging sequence of the tree in a line. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

8
12 11 20 17 1 15 8 5
12 20 17 11 15 8 5 1

Sample Output:

1 11 5 8 17 12 20 15

题目大意:给定中序和后序可以确定一棵树,并输出蛇形的层序序列; 

解题思路:

  • dfs可以做到两件事:
    • 按照中序和后序遍历(建)树,模板:
      • 左子树:dfs(posR - inL + i - 1,inL,i-1);
      • 右子树:dfs(posR -1,i + 1,inR);
    • 每一层递归存放层序的结点,dfs加一个深度dep即可;
    • 最后遍历二维vetocr,输出mod2的蛇形序列。
#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
#define rep(i,j,k)    for(int i=j;i<k;i++)
vector<int> in,post,level[30];
int maxDep = -1;
void dfs(int u,int l,int r,int dep){
    if(l>r){
        if(maxDep < dep)
            maxDep = dep;
        return;
    }
    int i = l;
    while(i<r && in[i] != post[u])    i++;
    level[dep].push_back(post[u]);
    dfs(u-r+i-1,l,i-1,dep+1);
    dfs(u-1,i+1,r,dep+1);
}
int main(){
    std::ios::sync_with_stdio(false);
    int n;
    cin>>n;
    in.resize(n);
    post.resize(n);
    rep(i,0,n)
    cin>>in[i];
    rep(i,0,n)
    cin>>post[i];
    dfs(n-1,0,n-1,0);
    printf("%d",level[0][0]);
    rep(i,0,maxDep){
        int j = i==0?1:0;
        int len = level[i].size();
        for(;j<len;j++)
            if(i % 2 == 1)
                printf(" %d",level[i][j]);
            else
                printf(" %d",level[i][len-j-1]);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值