Dice

There are 2 special dices on the table. On each face of the dice, a distinct number was written. Consider a 1.a 2,a 3,a 4,a 5,a 6 to be numbers written on top face, bottom face, left face, right face, front face and back face of dice A. Similarly, consider b 1.b 2,b 3,b 4,b 5,b 6 to be numbers on specific faces of dice B. It’s guaranteed that all numbers written on dices are integers no smaller than 1 and no more than 6 while a i ≠ a j and b i ≠ b j for all i ≠ j. Specially, sum of numbers on opposite faces may not be 7.

At the beginning, the two dices may face different(which means there exist some i, a i ≠ b i). Ddy wants to make the two dices look the same from all directions(which means for all i, a i = b i) only by the following four rotation operations.(Please read the picture for more information)


Now Ddy wants to calculate the minimal steps that he has to take to achieve his goal.
Input
There are multiple test cases. Please process till EOF.

For each case, the first line consists of six integers a 1,a 2,a 3,a 4,a 5,a 6, representing the numbers on dice A.

The second line consists of six integers b 1,b 2,b 3,b 4,b 5,b 6, representing the numbers on dice B.
Output
For each test case, print a line with a number representing the answer. If there’s no way to make two dices exactly the same, output -1.
Sample Input
1 2 3 4 5 6
1 2 3 4 5 6
1 2 3 4 5 6
1 2 5 6 4 3
1 2 3 4 5 6
1 4 2 5 3 6
Sample Output

0

3

-1

有两个四方体,每个表面都有相同的数字,你可以让它左翻转,右翻转,前翻转,后翻转,问你经过一系列翻转使得第一个和第二个四方体的同方向上同数字相同的最小翻转步数是多少

思路:直接搜索,知道搜到和第二个状态相同的时候结束

#include<stdio.h>
#include<iostream>
#include<string.h>
#include<algorithm>
#include<queue>
using namespace std;
struct node
{
    int c[6],d[6];
    int bu;
};
int vis[7][7][7][7][7][7];
int dfs(node a,node b)
{
    memset(vis,0,sizeof(vis));
    a.bu=0;
    queue<node>q;
    vis[a.c[0]][a.c[1]][a.c[2]][a.c[3]][a.c[4]][a.c[5]]=1;
    q.push(a);
    while(!q.empty())
    {
        node we;
        we=q.front();
        q.pop();
        if(we.c[0]==b.d[0]&&we.c[1]==b.d[1]&&we.c[2]==b.d[2]&&we.c[3]==b.d[3]&&we.c[4]==b.d[4]&&we.c[5]==b.d[5])
        {
            return we.bu;
        }
        else
        {
            node ni,ni1,ni2,ni3;
            ni.c[0]=we.c[3];
            ni.c[1]=we.c[2];
            ni.c[2]=we.c[0];
            ni.c[3]=we.c[1];
            ni.c[4]=we.c[4];
            ni.c[5]=we.c[5];

            ni1.c[0]=we.c[2];
            ni1.c[1]=we.c[3];
            ni1.c[2]=we.c[1];
            ni1.c[3]=we.c[0];
            ni1.c[4]=we.c[4];
            ni1.c[5]=we.c[5];

            ni2.c[0]=we.c[5];
            ni2.c[1]=we.c[4];
            ni2.c[2]=we.c[2];
            ni2.c[3]=we.c[3];
            ni2.c[4]=we.c[0];
            ni2.c[5]=we.c[1];

            ni3.c[0]=we.c[4];
            ni3.c[1]=we.c[5];
            ni3.c[2]=we.c[2];
            ni3.c[3]=we.c[3];
            ni3.c[4]=we.c[1];
            ni3.c[5]=we.c[0];

            if(!vis[ni.c[0]][ni.c[1]][ni.c[2]][ni.c[3]][ni.c[4]][ni.c[5]])
            {
                ni.bu=we.bu+1;
                vis[ni.c[0]][ni.c[1]][ni.c[2]][ni.c[3]][ni.c[4]][ni.c[5]]=1;
                q.push(ni);
            }
            if(!vis[ni1.c[0]][ni1.c[1]][ni1.c[2]][ni1.c[3]][ni1.c[4]][ni1.c[5]])
            {
                ni1.bu=we.bu+1;
                vis[ni1.c[0]][ni1.c[1]][ni1.c[2]][ni1.c[3]][ni1.c[4]][ni1.c[5]]=1;
                q.push(ni1);
            }
            if(!vis[ni2.c[0]][ni2.c[1]][ni2.c[2]][ni2.c[3]][ni2.c[4]][ni2.c[5]])
            {
                ni2.bu=we.bu+1;
                vis[ni2.c[0]][ni2.c[1]][ni2.c[2]][ni2.c[3]][ni2.c[4]][ni2.c[5]]=1;
               q.push(ni2);
            }
            if(!vis[ni3.c[0]][ni3.c[1]][ni3.c[2]][ni3.c[3]][ni3.c[4]][ni3.c[5]])
            {
                ni3.bu=we.bu+1;
                vis[ni3.c[0]][ni3.c[1]][ni3.c[2]][ni3.c[3]][ni3.c[4]][ni3.c[5]]=1;
                q.push(ni3);
            }
        }
    }
    return -1;
}
int main()
{
    node ha,haha;
   while(scanf("%d",&ha.c[0])!=-1)
   {
       for(int i=1;i<6;i++)
       {
           scanf("%d",&ha.c[i]);
       }
       for(int i=0;i<6;i++)
       {
           scanf("%d",&haha.d[i]);
       }
      printf("%d\n",dfs(ha,haha));
   }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值