1060 Are They Equal (25point(s))
If a machine can save only 3 significant digits, the float numbers 12300 and 12358.9 are considered equal since they are both saved as 0.123×10
5
with simple chopping. Now given the number of significant digits on a machine and two float numbers, you are supposed to tell if they are treated equal in that machine.
Input Specification:
Each input file contains one test case which gives three numbers N, A and B, where N (<100) is the number of significant digits, and A and B are the two float numbers to be compared. Each float number is non-negative, no greater than 10
100
, and that its total digit number is less than 100.
Output Specification:
For each test case, print in a line YES if the two numbers are treated equal, and then the number in the standard form 0.d[1]…d[N]*10^k (d[1]>0 unless the number is 0); or NO if they are not treated equal, and then the two numbers in their standard form. All the terms must be separated by a space, with no extra space at the end of a line.
Note: Simple chopping is assumed without rounding.
Sample Input 1:
3 12300 12358.9
Sample Output 1:
YES 0.12310^5
Sample Input 2:
3 120 128
Sample Output 2:
NO 0.12010^3 0.128*10^3
#include<bits/stdc++.h>
using namespace std;
string deal(string str,int &e,int n)
{
unsigned int k = 0;
while (str.length()>0&&str[0] == '0')
str.erase(str.begin());
if (str[0] == '.')
{
str.erase(str.begin());
while (str.length() > 0 && str[0] == '0')
{
str.erase(str.begin());
e--;
}
}
else
{
while (k <str.length()&&str[k] != '.')
{
k++;
e++;
}
if (k < str.length())
str.erase(str.begin()+k);
}
if (str.length() == 0)
e = 0;
k = 0;
string ans="0.";
for (int i = 0; i < n; ++i)
{
if (k < str.length())
ans+= str[k++];
else
ans+= '0';
}
return ans;
}
int main()
{
int N;
string A, B;
int e1 = 0, e2 = 0;
cin >> N >> A >> B;
string AA = deal(A,e1,N);
string BB = deal(B,e2, N);
if (AA == BB && e1 == e2)
cout << "YES " << AA << "*10^" << e1<<endl;
else
cout << "NO " << AA << "*10^" << e1 << " " << BB << "*10^" << e2<<endl;
}