PAT-A1070 Mooncake (结构体+排序)

A1070 Mooncake (结构体+排序)

Mooncake is a Chinese bakery product traditionally eaten during the Mid-Autumn Festival. Many types of fillings and crusts can be found in traditional mooncakes according to the region’s culture. Now given the inventory amounts and the prices of all kinds of the mooncakes, together with the maximum total demand of the market, you are supposed to tell the maximum profit that can be made.

Note: partial inventory storage can be taken. The sample shows the following situation: given three kinds of mooncakes with inventory amounts being 180, 150, and 100 thousand tons, and the prices being 7.5, 7.2, and 4.5 billion yuans. If the market demand can be at most 200 thousand tons, the best we can do is to sell 150 thousand tons of the second kind of mooncake, and 50 thousand tons of the third kind. Hence the total profit is 7.2 + 4.5/2 = 9.45 (billion yuans).

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (≤1000), the number of different kinds of mooncakes, and D (≤500 thousand tons), the maximum total demand of the market. Then the second line gives the positive inventory amounts (in thousand tons), and the third line gives the positive prices (in billion yuans) of N kinds of mooncakes. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the maximum profit (in billion yuans) in one line, accurate up to 2 decimal places.

Sample Input:

3 200
180 150 100
7.5 7.2 4.5结尾无空行

Sample Output:

9.45

结尾无空行

分析:

注意在后面运算总利润的时候要注意月饼的数量必须要是double类型,否则int和double类型的数进行乘除法默认是没有小数的,像0.5就默认是0

这题一开始我也有些蒙圈,不过后来我发现其实就是先计算每种月饼的单利润,先卖单利润最高的月饼,然后再卖单利润次之的月饼

月饼的单利润可以这样计算:钱数/月饼总数量(为了好看可以*100,)

代码如下:

#include<cstdio>
#include<algorithm>
using namespace std;
const int maxn=1010;
struct Moon{
	double num;
	double price;
	double prices;
}M[maxn];
bool cmp(Moon a,Moon b){
	return a.prices>b.prices;
}
int main(){
	int m,n;
	double temp=0;
	scanf("%d %d",&m,&n);
	for(int i=0;i<m;i++){
		scanf("%lf",&M[i].num);
	}
	for(int i=0;i<m;i++){
		scanf("%lf",&M[i].price);
		M[i].prices=M[i].price*100/M[i].num;
	}
	sort(M,M+m,cmp);
	temp=0;
	for(int i=0;i<m;i++){
		if(M[i].num<n){
			temp+=M[i].price;
			n-=M[i].num;
		}else{
			temp=temp+(n/M[i].num)*M[i].price;
			break;
		}
	}
	printf("%.2f",temp);
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值