『1127』ZigZagging on a Tree

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences. And it is a simple standard routine to print the numbers in level-order. However, if you think the problem is too simple, then you are too naive. This time you are supposed to print the numbers in “zigzagging order” – that is, starting from the root, print the numbers level-by-level, alternating between left to right and right to left. For example, for the following tree you must output: 1 11 5 8 17 12 20 15.

zigzag.jpg

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer , the total number of nodes in the binary tree. The second line gives the inorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the zigzagging sequence of the tree in a line. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

8
12 11 20 17 1 15 8 5
12 20 17 11 15 8 5 1

Sample Output:

1 11 5 8 17 12 20 15

Ω

给出一棵二叉树的中序遍历和后续遍历,输出其ZigZag遍历结果。花样真多啊,就是S形的层次遍历,先从左到右,再从右到左。

树的根节点都在后续遍历中的最后一位,然后再通过中序遍历中根节点的位置得知左右子树的节点,在后续遍历中划分完递归划分子树,记录每个节点的左右子节点。最后设置一个flag布尔变量表示顺序,每次都 即可。


🐎

#include <iostream>
#include <vector>
#include <map>
#include <algorithm>

using namespace std;
map<int, pair<int, int>> sons;
vector<int> post, in;

void build(int is, int ie, int ps, int pe)
{
    int bias = (find(in.begin(), in.end(), post[pe]) - in.begin()) - is;
    if (bias > 0)
    {
        sons[post[pe]].first = post[ps + bias - 1];
        build(is, is + bias - 1, ps, ps + bias - 1);
    }
    if (bias + is < ie)
    {
        sons[post[pe]].second = post[pe - 1];
        build(is + bias + 1, ie, ps + bias, pe - 1);
    }
}

int main()
{
    int n;
    cin >> n;
    post.resize(n), in.resize(n);
    for (auto &k: in) cin >> k;
    for (auto &k: post) cin >> k;
    build(0, n - 1, 0, n - 1);
    vector<int> crt{post.back()}, nxt;
    bool flag = false, space = false;
    while (!crt.empty())
    {
        for (auto &k: crt)
        {
            if (sons[k].first) nxt.push_back(sons[k].first);
            if (sons[k].second) nxt.push_back(sons[k].second);
        }
        if (flag)
            for (auto &k: crt) 
                printf("%s%d", space ? " " : (space = true, ""), k);
        else
            for (auto it = crt.rbegin(); it != crt.rend(); ++it)
                printf("%s%d", space ? " " : (space = true, ""), *it);
        crt = std::move(nxt), nxt = vector<int>(), flag = !flag;
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值