「1041」Be Unique

Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1,104]. The first one who bets on a unique number wins. For example, if there are 7 people betting on { 5 31 5 88 67 88 17 }, then the second one who bets on 31 wins.

Input Specification:

Each input file contains one test case. Each case contains a line which begins with a positive integer N (≤ ) and then followed by N bets. The numbers are separated by a space.

Output Specification:

For each test case, print the winning number in a line. If there is no winner, print None instead.

Sample Input 1:

7 5 31 5 88 67 88 17

Sample Output 1:

31

Sample Input 2:

5 888 666 666 888 888

Sample Output 2:

None

Ω

我老家那边卖彩票,规则很有趣,第一个买到唯一数字的人中奖。按照时间顺序给出所有买家所买的数字,要求输出winner的数字,没有则None。

那么可以用一个vector来记录彩票数字的时间顺序,那么如何快速判断在此之前是否已有相同数字呢。这里我另外用了一个map建立起了(lottery number,vector index)的映射,从而能快速找到vector中的位置,找到后直接将其的中奖资格置false,因此vector的类型为<int,bool>,最后再从头找的一个true的数字即可。


C ☺ D E

#include <iostream>
#include <vector>
#include <map>

using namespace std;

int main()
{
    int n, m;
    cin >> n;
    vector<pair<int, bool>> lottery;
    map<int, int> idx;
    for (int i = 0; i < n; ++i)
    {
        cin >> m;
        if (idx.find(m) == idx.end())
        {
            idx[m] = lottery.size();
            lottery.push_back({m, true});
        }
        else
            lottery[idx[m]].second = false;
    }
    for (auto &k: lottery)
        if (k.second)
        {
            cout << k.first;
            return 0;
        }
    cout << "None";
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值