HDU 2141 Can you find it?

题目:

Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.
Input
There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.
Output
For each case, firstly you have to print the case number as the form “Case d:”, then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print “YES”, otherwise print “NO”.
Sample Input
3 3 3
1 2 3
1 2 3
1 2 3
3
1
4
10
Sample Output
Case 1:
NO
YES
NO

题意:

有三个数组A、B、C,问是否存在Ai、Bi、Ci,使得Ai+Bi+Ci=X。

分析:

典型的二分题。如果用三个for循环暴力解决,时间复杂度为O(n^3)。考虑对其中两个数组求和并排序,再枚举将另一个数组,对和数组进行二分查找A+B=X-C。

#include <iostream>
#include <algorithm>
using namespace std;
const int max1=505;
int l,n,m,s,x,bci;   //bci即B、C数组合并后的元素数量
int a[max1],b[max1],c[max1*max1];
bool findx()
{

    for(int i=0;i<l;++i)
    {
        int lo=0,hi=bci-1,mid;
        while(lo<=hi)
        {
            mid=(lo+hi)>>1;
            if(c[mid]+a[i]==x) return true;
            else if(c[mid]+a[i]>x)  hi=mid-1;
            else lo=mid+1;
        }
    }
    return false;
}
int main()
{
    int d=0;
    while(cin>>l>>n>>m)
    {
        for(int i=0;i<l;++i)    cin>>a[i];
        for(int i=0;i<n;++i)    cin>>b[i];
        bci=0;
        int temp;
        for(int i=0;i<m;++i){
            cin>>temp;
            for(int j=0;j<n;++j){
                c[bci++]=b[j]+temp;
            }
        }    //  c数组存放b+c
        sort(c,c+bci);
        cin>>s;     cout<<"Case "<<++d<<":"<<endl;
        while(s--)
        {
            cin>>x;
            //枚举a数组,二分c数组
            if(findx())    cout<<"YES"<<endl;
            else    cout<<"NO"<<endl;
        }
    }
    return 0;
}

下面利用binary_search(),更简洁,但用时稍多。

#include <iostream>
#include <algorithm>
using namespace std;
const int max1=505;
int a[max1],b[max1],c[max1],bc[max1*max1];
int main()
{
    int d=0;
    int l,n,m,s,x,bci=0;
    while(cin>>l>>n>>m)
    {
        bci=0;
        for(int i=0;i<l;++i)    cin>>a[i];
        for(int i=0;i<n;++i)    cin>>b[i];
        for(int i=0;i<m;++i)    cin>>c[i];
        for(int i=0;i<n;++i)
            for(int j=0;j<m;++j)
                bc[bci++]=b[i]+c[j];
        sort(bc,bc+bci);
        cin>>s;     cout<<"Case "<<++d<<":"<<endl;
        while(s--)
        {
            cin>>x;
            int cnt=0;
            for(int i=0;i<l;++i)
            {
                if(binary_search(bc,bc+bci,x-a[i]))
                    {cnt=1;break;}
            }
            if(cnt)    cout<<"YES"<<endl;
            else    cout<<"NO"<<endl;
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值