HDU 3613 Best Reward

Best Reward

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 3458    Accepted Submission(s): 1412


Problem Description
After an uphill battle, General Li won a great victory. Now the head of state decide to reward him with honor and treasures for his great exploit. 

One of these treasures is a necklace made up of 26 different kinds of gemstones, and the length of the necklace is n. (That is to say: n gemstones are stringed together to constitute this necklace, and each of these gemstones belongs to only one of the 26 kinds.) 

In accordance with the classical view, a necklace is valuable if and only if it is a palindrome - the necklace looks the same in either direction. However, the necklace we mentioned above may not a palindrome at the beginning. So the head of state decide to cut the necklace into two part, and then give both of them to General Li. 

All gemstones of the same kind has the same value (may be positive or negative because of their quality - some kinds are beautiful while some others may looks just like normal stones). A necklace that is palindrom has value equal to the sum of its gemstones' value. while a necklace that is not palindrom has value zero. 

Now the problem is: how to cut the given necklace so that the sum of the two necklaces's value is greatest. Output this value. 

 

Input
The first line of input is a single integer T (1 ≤ T ≤ 10) - the number of test cases. The description of these test cases follows. 

For each test case, the first line is 26 integers: v 1, v 2, ..., v 26 (-100 ≤ v i ≤ 100, 1 ≤ i ≤ 26), represent the value of gemstones of each kind. 

The second line of each test case is a string made up of charactor 'a' to 'z'. representing the necklace. Different charactor representing different kinds of gemstones, and the value of 'a' is v 1, the value of 'b' is v 2, ..., and so on. The length of the string is no more than 500000. 

 

Output
Output a single Integer: the maximum value General Li can get from the necklace.
 

Sample Input
 
 
2 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 aba 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 acacac
 

Sample Output
 
 
1 6
 
解题思路:先利用扩展KMP求出串中的前缀和后缀回文串,在依次计算价值的最大值

代码如下:

# include<stdio.h>
# include<string.h>
char a[500005],b[500005];
int ex1[500005],ex2[500005],next[500005],sum[500005];
void GETNEXT(char *str)  
{  
	int i=0,j,po,len=strlen(str);  
    next[0]=len;
    while(str[i]==str[i+1]&&i+1<len)//计算next[1]  
    i++;  
    next[1]=i;  
    po=1;//初始化po的位置  
    for(i=2;i<len;i++)  
    {  
        if(next[i-po]+i<next[po]+po)//第一种情况,可以直接得到next[i]的值  
        next[i]=next[i-po];  
        else//第二种情况,要继续匹配才能得到next[i]的值  
        {  
            j=next[po]+po-i;  
            if(j<0)j=0;//如果i>po+next[po],则要从头开始匹配  
            while(i+j<len&&str[j]==str[j+i])//计算next[i]  
            j++;  
            next[i]=j;  
            po=i;//更新po的位置  
        }  
    }  
}  
void EXKMP(char *s1,char *s2,int * ex)  
{  
    int i=0,j,po,len=strlen(s1),l2=strlen(s2);  
    GETNEXT(s2);//计算子串的next数组  
    while(s1[i]==s2[i]&&i<l2&&i<len)//计算ex[0]  
    i++;  
    ex[0]=i;  
    po=0;//初始化po的位置  
    for(i=1;i<len;i++)  
    {  
        if(next[i-po]+i<ex[po]+po)//第一种情况,直接可以得到ex[i]的值  
        ex[i]=next[i-po];  
        else//第二种情况,要继续匹配才能得到ex[i]的值  
        {  
            j=ex[po]+po-i;  
            if(j<0)j=0;//如果i>ex[po]+po则要从头开始匹配  
            while(i+j<len&&j<l2&&s1[j+i]==s2[j])//计算ex[i]  
            j++;  
            ex[i]=j;  
            po=i;//更新po的位置  
        }  
    }  
}  
int main(){
	int t;	
	scanf("%d",&t);
	while(t--)
	{
		int c[26];
		for(int i=0;i<26;i++)
		scanf("%d",&c[i]);
		getchar();
		scanf("%s",a);
		int len=strlen(a);
		sum[0]=c[a[0]-'a'];
		for(int i=1;i<len;i++)
		{
			sum[i]=sum[i-1]+c[a[i]-'a'];				
		}
		for(int i=len-1,j=0;i>=0;i--,j++)
		b[j]=a[i];
		EXKMP(a,b,ex1);
		EXKMP(b,a,ex2);
		int max=0;
		for(int i=1;i<len;i++)
		{	int ans=0;
			//判断前缀回文的条件 
			if(ex2[len-i]+len-i==len) 
			{
				ans+=sum[i-1];
			}
			//判断后缀回文的条件 
			if(ex1[i]+i==len)
			{
				ans+=sum[len-1]-sum[i-1];
			}
			if(max<ans)
			max=ans;
		}	
		printf("%d\n",max);
	}	
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值