OSPF---路由备份的设计实验

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/xuchonghao/article/details/70094468

    题目:设计型实验2(路由备份的设计)
    网络可靠性的设计包括链路备份和设备备份两大类。路由备份是链路备份的一种方式。
    动态路由协议能够自动发现路由,生成路由表。动态路由协议的特性决定了它也可以用于链路备份。在一个到达目的地具有冗余路径的网络中,根据动态路由协议的原理,动态路由协议会把发现的最佳到达目的地的路由添加到路由表中,如果由于某种原因,这条最佳路由出现问题而被删除,那么动态路由协议会重新计算到达目的地的路由,这时就会使用动态路由协议重新计算得到的次优路由到达目的地,从而保证网络不会出现长时间中断,达到备份的目的。
    下图所示的拓扑结构提供了简单的路由备份。R1、R2和S1所组成的网络运行OSPF协议实现互联,对用户PC1和PC2提供访问互联网的服务。通过为各条连线设置不同的花费值,可以使所有的PC通过指定路径访问互联网。图中各线条上所标的粗体字为花费值,指定路径为 S1-R1-Internet。若S1-R1路径出现故障,路由协议会自动选取S1-R2-Internet作为新的路径,保持网络畅通。若R2-Internet也发生故障,则将S1-R2-RI-Internet作为新的路径。
    要求:
    1) 整个设计的说明
    2) 列出基本配置:IP、VLAN
    3) OSPF的基本配置
    4) 路由备份配置:OSPF、静态路由等
    5) 实验验证截图

步骤:
一、组好网,配置好vlan、接口ip、ospf、area、network、cost。(配置时间比较长,页面消失了,所以显示了一下最后的配置,后面有)
二、使用PC1 ping R1的E1接口(192.168.3.1)是不通的,因此首先在S1中引入直连路由(import-route direct),PC1可以ping通R1的E1接口。
三、使用PC1 ping R1的E0接口(202.112.1.1)是不通的,因此首先在R1中引入直连路由(import-route direct),PC1可以ping通R1的E0接口。 R2同理
四、使用PC1 ping S2的VLAN 2接口(202.112.1.2)是不通的,是由于S2交换机在Area0的外面,于是在R1中设置R2的静态路由并引入ospf中:(R2同理)
ip route-static 211.100.2.1 255.255.255.0 202.112.1.2
ospf
R1-ospf]import-route static cost 100
五、此时使用PC1 ping S2的VLAN 2接口(202.112.1.2)或者Loop1的地址仍然不通,是因为从S2到PC1的网络没有回来的路由,于是在S2中设置回到PC所在网络的静态路由,通过路由聚合,并使R1到S2的优先级高于R2到S2的优先级:
[S2]ip route-static 192.168.0.0 255.255.0.0 202.112.1.1 pre 50
[S2]ip route-static 192.168.0.0 255.255.0.0 202.112.2.1 pre 60
六、使用PC1pingS2的Loop1,发现通了,配置成功!
七、备份测试:
1、在PC1输入:tracert -d 211.100.2.1,输出显示见图片
2、shutdownR1的E1接口
3、在PC1输入:tracert -d 211.100.2.1,输出显示见图片
4、shutdownR2的E0接口
5、在PC1输入:tracert -d 211.100.2.1,输出显示见图片
八、结果:
第一次:192.168.5.1-----》192.168.3.1-----》211.100.2.1,符合路线
第二次:192.168.5.1-----》192.168.4.1-----》211.100.2.1,符合路线
第三次:192.168.5.1-----》192.168.4.1-----》192.168.0.1-----》211.100.2.1,符合路线
试验成功!!!


说明:tracert命令,一切正常,但返回* * *
          注:新设备需要启用,输入以下命令即可:
//[S1]ip ttl-expires enable
//[S1]ip unreachables enable  

1、对S1的主要配置显示如下(部分删除):
[H3C]display current-configuration
#
ip ttl-expires enable
ip unreachables enable
#
undo ip http enable
#
password-recovery enable
#
vlan 1
#
vlan 2 to 4
#
interface Vlan-interface1 //这个接口要shutdown
ip address 192.168.3.2 255.255.255.0
ospf cost 100
#
interface Vlan-interface2
ip address 192.168.5.1 255.255.255.0
#
interface Vlan-interface3
ip address 192.168.4.2 255.255.255.0
ospf cost 200
#
interface Vlan-interface4
ip address 192.168.6.1 255.255.255.0
#
interface Ethernet1/0/1
port link-mode bridge
。。。。。。。。。<省略>
#
interface GigabitEthernet1/0/28
port link-mode bridge
#
ospf 1
import-route direct
area 0.0.0.0
network 192.168.3.0 0.0.0.255
network 192.168.4.0 0.0.0.255

2、对S2的配置显示如下
<H3C>sys
System View: return to User View with Ctrl+Z.
[H3C]ip route
[H3C]ip route-static 192.168.0.0 255.255.0.0 202.112.2.1
[H3C]ip ttl-expires enable
[H3C]ip unreachables enable
<H3C>display current-configuration
#
ip ttl-expires enable
ip unreachables enable

#
vlan 1
#
vlan 2 to 3

#
interface NULL0
#
interface LoopBack1
ip address 211.100.2.1 255.255.255.255
#
interface Vlan-interface1
ip address dhcp-alloc client-identifier mac Vlan-interface1
#
interface Vlan-interface2
ip address 202.112.1.2 255.255.255.0
#
interface Vlan-interface3
ip address 202.112.2.2 255.255.255.0
#
interface Ethernet1/0/1
port link-mode bridge
port access vlan 2
#
interface Ethernet1/0/2
port link-mode bridge
port access vlan 3
。。。。。。。<省略>
#
interface GigabitEthernet1/0/28
port link-mode bridge
#
ospf 1
import-route direct
#
ip route-static 192.168.0.0 255.255.0.0 202.112.1.1 pre50
ip route-static 192.168.0.0 255.255.0.0 202.112.2.1 pre 60

3、对R1的配置如下
<H3C>display current-configuration
关键配置显示如下
#
ip ttl-expires enable
ip unreachables enable

interface Ethernet0/0 //这里要shutdown
port link-mode route
ip address 202.112.1.1 255.255.255.0
#
interface Ethernet0/1
port link-mode route
ip address 192.168.3.1 255.255.255.0
ospf cost 100
#
interface Serial1/0
link-protocol ppp
ip address 192.168.0.1 255.255.255.0
ospf cost 200
#
interface Serial2/0
link-protocol ppp
#
interface NULL0
#
interface Ethernet0/2
port link-mode bridge
。。。。。。。。。<省略>
interface Ethernet0/49
port link-mode bridge
#
ospf 1
import-route direct
import-route static
area 0.0.0.0
network 192.168.3.0 0.0.0.255
network 192.168.0.0 0.0.0.255
#
ip route-static 211.100.2.0 255.255.255.0 202.112.1.2
4、对R2配置显示如下:
<H3C>sys
System View: return to User View with Ctrl+Z.
[H3C]ip route
[H3C]ip route-static 211.100.2.1 24 202.112.2.2
[H3C]ospf
[H3C-ospf-1]import-route static
[H3C-ospf-1]undo import-route static
[H3C-ospf-1]quit
[H3C]undo ip route-static 211.100.2.1 24 202.112.2.2
[H3C]ip route-static 202.112.2.2 24 202.112.2.2
[H3C]ospf
[H3C-ospf-1]imp
[H3C-ospf-1]import-route static
[H3C-ospf-1]quit
[H3C]ip ttl
[H3C]ip ttl-expires ena
[H3C]ip ttl-expires enable
[H3C]ip un
[H3C]ip unreachables enabl
[H3C]
[H3C]ip unreachables enabl
[H3C]ip unreachables enable
[H3C]int Ethernet 0/0
[H3C-Ethernet0/0]shutdown
[H3C-Ethernet0/0]undo shutdown

[H3C]display current-configuration 主要配置显示如下:
ip ttl-expires enable
ip unreachables enable

#
vlan 1
#
interface Ethernet0/0
port link-mode route
ip address 202.112.2.1 255.255.255.0
#
interface Ethernet0/1
port link-mode route
ip address 192.168.4.1 255.255.255.0
ospf cost 200
#
interface Serial1/0
link-protocol ppp
ip address 192.168.0.2 255.255.255.0
ospf cost 200
#
interface Serial2/0
link-protocol ppp
#
interface NULL0
.................<省略>
#
ospf 1
import-route direct
import-route static
area 0.0.0.0
network 192.168.4.0 0.0.0.255
network 192.168.0.0 0.0.0.255
#
ip route-static 202.112.2.0 255.255.255.0 202.112.2.2


阅读更多

没有更多推荐了,返回首页