nim博弈_______Georgia and Bob( poj 1704 )

Description

Georgia and Bob decide to play a self-invented game. They draw a row of grids on paper, number the grids from left to right by 1, 2, 3, ..., and place N chessmen on different grids, as shown in the following figure for example: 


Georgia and Bob move the chessmen in turn. Every time a player will choose a chessman, and move it to the left without going over any other chessmen or across the left edge. The player can freely choose number of steps the chessman moves, with the constraint that the chessman must be moved at least ONE step and one grid can at most contains ONE single chessman. The player who cannot make a move loses the game. 

Georgia always plays first since "Lady first". Suppose that Georgia and Bob both do their best in the game, i.e., if one of them knows a way to win the game, he or she will be able to carry it out. 

Given the initial positions of the n chessmen, can you predict who will finally win the game? 

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case contains two lines. The first line consists of one integer N (1 <= N <= 1000), indicating the number of chessmen. The second line contains N different integers P1, P2 ... Pn (1 <= Pi <= 10000), which are the initial positions of the n chessmen.

Output

For each test case, prints a single line, "Georgia will win", if Georgia will win the game; "Bob will win", if Bob will win the game; otherwise 'Not sure'.

Sample Input

2
3
1 2 3
8
1 5 6 7 9 12 14 17

Sample Output

Bob will win
Georgia will win



题目意思:

在1*M的一个棋盘上有N个棋子,现在两个人轮流移动棋子,移动棋子的时候只能选择某个棋子左移至少一步,但是不能越过任何棋子。当某人无法移动的时候算输。


分析:

感觉这个题目的sg值不好求,因为每个棋子的SG值还要取决左边棋子的位置。但是我们可以换位思考,如果一个棋子左移X步,那么这个棋子后面的一个棋子也能同样的左移X步。所以,我们可以尝试将棋子成对的计算,

假设N为偶数,那么我们将相邻的棋子两两成对(1-2,3-4.....)这样。每次移动就是一定是移动的某对的左棋子或者右棋子。当然如果移动左棋子,那么对方一定可以移动相同步右棋子维持两个棋子距离相同。如果移动的是右棋子,那么这对棋子的距离可能面临无法再复原。并且当这对棋子距离为1(紧挨)的时候。这对棋子对先手已经不能贡献了。因为先手只能移动左棋子。而后手也能同样移动右棋子相同步数恢复原状。所以我们可以知道其实真正的变化不在于成对棋子的位置,而是在于成对棋子的距离。我们就可以吧每对的两棋子之间的距离看作一堆石子。

移动右棋子就相当于从石堆里面拿石子,如果移动左棋子,对手可以同样移动右棋子让对方回复原来的状态。那么这就是一个anim博弈了。当每对棋子之间的距离为1的时候就赢了。


当N为奇数的时候我们可以假设还有个棋子在0位置,并且将这个棋子跟左边第一个棋子配对。



代码:


#include <stdio.h>
#include<algorithm>
using namespace std;
int a[1010];
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n,ans = 0,step;
        scanf("%d",&n);
        for(int i = 0 ; i < n ; i ++)
            scanf("%d",&a[i]);
        sort(a,a+n);
        int t = 0;
        if(n%2 == 1) ans ^= (a[t++] - 1);
        while(t < n)
        {
            ans ^= (a[t+1] - a[t] - 1);
            t += 2;
        }
        if(ans) printf("Georgia will win\n");
        else printf("Bob will win\n");
    }
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值