Charm Bracelet

8 篇文章 0 订阅

题目:

描述

Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N(1 ≤ N≤ 3,402) available charms. Each charm iin the supplied list has a weight Wi(1 ≤ Wi≤ 400), a 'desirability' factor Di(1 ≤ Di≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M(1 ≤ M≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.


输入
Line 1: Two space-separated integers: N and M
Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: W i and D i
输出
Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints
样例输入
4 6
1 4
2 6
3 12
2 7
样例输出
23

个人见解:0-1背包问题。一共拥有N件物品,要放入一个背包里面,总重量不能超过M,Wi表示第i件物品的重量,Di表示第i件物品的价值。求如何选择装入背包中的物品,使得装入背包中的物品的总价值最大?

   在选择装入背包的物品中,对每种物品i只有两种选择,即装入或者不装入背包。

1、对于重量大于背包容量的物品自然是不能放入背包中的。

2、对于重量小于等于背包容量 的物品来说,有两种情况。一是放入第i个物品,则背包中物品的价值为i-1个物品放入容量为j-Wi背包中的价值加上第i个物品的价值Di;二是不放入第i个物品,背包的价值为i-1个物品放入容量为j的背包中的价值。取二者中价值最大的作为把i个物品放入容量为j的背包中的最优解。

源代码:

#include<iostream>
#include<algorithm>
using namespace std;
const int N = 3402;
const int M = 12880;
int maxm[M] = { 0 };
int main()
{
	int n, m;
	cin >> n >> m;
	int W[N], D[N];

	for (int i = 1; i <= n; i++)
		cin >> W[i] >> D[i];

	for (int i = 1; i <= n; i++)
	{
		for (int j = m; j >= W[i]; j--)
		{
			maxm[j] = max(maxm[j - W[i]] + D[i], maxm[j]);
		}
	}
	cout << maxm[m] << endl;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值