POJ1125_Stockbroker Grapevine_最短路::弗洛伊德

Stockbroker Grapevine
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 35510 Accepted: 19711

Description

Stockbrokers are known to overreact to rumours. You have been contracted to develop a method of spreading disinformation amongst the stockbrokers to give your employer the tactical edge in the stock market. For maximum effect, you have to spread the rumours in the fastest possible way. 

Unfortunately for you, stockbrokers only trust information coming from their "Trusted sources" This means you have to take into account the structure of their contacts when starting a rumour. It takes a certain amount of time for a specific stockbroker to pass the rumour on to each of his colleagues. Your task will be to write a program that tells you which stockbroker to choose as your starting point for the rumour, as well as the time it will take for the rumour to spread throughout the stockbroker community. This duration is measured as the time needed for the last person to receive the information.

Input

Your program will input data for different sets of stockbrokers. Each set starts with a line with the number of stockbrokers. Following this is a line for each stockbroker which contains the number of people who they have contact with, who these people are, and the time taken for them to pass the message to each person. The format of each stockbroker line is as follows: The line starts with the number of contacts (n), followed by n pairs of integers, one pair for each contact. Each pair lists first a number referring to the contact (e.g. a '1' means person number one in the set), followed by the time in minutes taken to pass a message to that person. There are no special punctuation symbols or spacing rules. 

Each person is numbered 1 through to the number of stockbrokers. The time taken to pass the message on will be between 1 and 10 minutes (inclusive), and the number of contacts will range between 0 and one less than the number of stockbrokers. The number of stockbrokers will range from 1 to 100. The input is terminated by a set of stockbrokers containing 0 (zero) people. 

Output

For each set of data, your program must output a single line containing the person who results in the fastest message transmission, and how long before the last person will receive any given message after you give it to this person, measured in integer minutes. 
It is possible that your program will receive a network of connections that excludes some persons, i.e. some people may be unreachable. If your program detects such a broken network, simply output the message "disjoint". Note that the time taken to pass the message from person A to person B is not necessarily the same as the time taken to pass it from B to A, if such transmission is possible at all.

Sample Input

3
2 2 4 3 5
2 1 2 3 6
2 1 2 2 2
5
3 4 4 2 8 5 3
1 5 8
4 1 6 4 10 2 7 5 2
0
2 2 5 1 5
0

Sample Output

3 2
3 10

大致题意:

现有n个点构成一个网络。要求信息从一点开始传播,向这个点所能直接到达的所有点同时传播,最后一个点获得消息的时间就是信息的传递时间。现要求找出一个点,以此点为起点时传递时间最短。


大体思路:

弗洛伊德算法求每个点到其他点的最短路,找最大值最小的那个点当前起点,这个最小的最大值就是答案。


#include<cstdio>

#define _max 2000

int Map [105][105];
int N;

int main ()
{
	while(scanf("%d",&N) && N!=0){

		for(int i=1; i<=N; i++){//距离初始化为无穷大
			for(int j=1; j<=N; j++)
				Map[i][j] = _max;
			Map[i][i] = 0;//点到自身的距离为0
		}

		int m, x, y;
		for(int i=1; i<=N; i++){

			scanf("%d",&m);//一个点的链接数
			for(int j=1; j<=m; j++){
				scanf("%d%d",&x,&y);//链接对象,距离
				Map[i][x] = y;
			}

		}
/*******弗洛伊德算法*******/
		for(int k=1; k<=N; k++)//枚举被利用的点
				for(int i=1; i<=N; i++)//枚举起点
					for(int j=1; j<=N; j++){//枚举终点
/****利用 被利用点 后的距离更小,则更新距离值****/
						if(Map[i][j] > Map[i][k] + Map[k][j]) Map[i][j] = Map[i][k] + Map[k][j];

					}

		int Min = _max, ans;//找出那个最小的最大值
		for(int i=1; i<=N; i++){

			int Max = 0;
			for(int j=1; j<=N; j++)
				if(Max < Map[i][j]) Max = Map[i][j];

			if(Min > Max) Min = Max, ans = i;

		}

		if(Min==_max) printf("disjoint\n");
		else printf("%d %d\n",ans,Min);

	}

	return 0;

}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值