Prime Ring Problem HDU - 1016 (dfs、(素数筛模板))

Prime Ring Problem

  HDU - 1016 

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime. 

Note: the number of first circle should always be 1. 

 
Inputn (0 < n < 20). 
OutputThe output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order. 

You are to write a program that completes above process. 

Print a blank line after each case. 
Sample Input
6
8
Sample Output
Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

题意:任意相邻两个数和为素数

思路:dfs

Java AC代码:

import java.util.Arrays;
import java.util.Scanner;

public class Main {
	static int maze[][] = new int[15][15];
	static int vis[] = new int [15];
	static int ans[] = new int [15];
	static int pri[] = new int [50];
	static int n,cnt,num;
	public static void main(String[] args) {
		// TODO Auto-generated method stub
		Scanner cin = new Scanner (System.in);
		cnt = 0;
		for(int i=2; i<=40; ++i)  
	        if(pri[i] == 0)  
	            for(int j=i+i; j<=40; j+=i)  
	                pri[j] = 1;  
	/*	for(int i=1;i<=40;++i)
			System.out.print(pri[i]+" ");
		System.out.println();*/
		while(cin.hasNext()){
			n = cin.nextInt();
			Arrays.fill(vis, 0);
			System.out.println("Case "+ ++cnt +":");
			vis[1] = 1;
			ans[1] = 1;
			dfs(2);
			System.out.println();
		}
	}
	static void dfs(int step){
		if(step==n+1){
			show();
			return;
		}
		
		for(int i =2;i<=n;++i){
			if(vis[i]==1 || pri[i+ans[step-1]]==1) continue;
			if(step ==n && pri[i+ans[1]]==1) 	   continue;
			vis[i] = 1;
			ans[step] = i;
			dfs(step+1);
			vis[i] = 0;
			ans[step] = 0;
			
		}
	}
	static void show(){
		for(int i=1;i<n;++i){
			System.out.print(ans[i]+" ");
		}
		System.out.println(ans[n]);
	}
}

素数筛:

k=0;  
    memset(pri,0,sizeof(pri));  
	for(int i=2;i<=1000;++i){
		if(pri[i]==0)num[k++] = i;
		for(int j=0;j<k&&num[j]*i<=1000;++j){
			pri[num[j]*i] = 1;
			if(i%num[j]==0) break;
		}
	}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值